Netduino home hardware projects downloads community

Jump to content

The Netduino forums have been replaced by new forums at This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

Upgraded to VS2012 -> System.MissingFieldException

NetMF4.3 VS2012 VisualStudio

Best Answer Chris Walker, 18 October 2013 - 09:04 PM

Hi mlsomers, Did you install the Netduino 4.3 SDK Beta? Chris Go to the full post

  • Please log in to reply
2 replies to this topic

#1 mlsomers



  • Members
  • PipPip
  • 10 posts

Posted 17 October 2013 - 08:41 PM

I've upgraded to Visual Studio 2012 Express and the .Net MicroFramework 4.3.


I upgraded my projects, but immediately after upgrading them, Visual Studio crashed.

Tried creating a new project from the "Netduino Plus 2 Application" template, accidently choosing Visual Basic as language (wich is default for some reason), and it didn't crash.


Then I closed that solution, and created a new one for c#, but bang! it crashed again. Tried it a few times, it even crashes on creating a fresh new NetMF class library.


This is the info I get from the crash dialog:


  Problem signature:   Problem Event Name:  CLR20r3   Problem Signature 01:  wdexpress.exe   Problem Signature 02:  11.0.50727.42   Problem Signature 03:  503ebe9f   Problem Signature 04:  Microsoft.VisualStudio.Progression.LanguageService.CSharp   Problem Signature 05:  11.0.50727.1   Problem Signature 06:  5011cc19   Problem Signature 07:  131   Problem Signature 08:  43   Problem Signature 09:  System.MissingFieldException   OS Version:  6.1.7601.   Locale ID:  1043   Additional Information 1:  0a9e   Additional Information 2:  0a9e372d3b4ad19135b953a78882e789   Additional Information 3:  0a9e   Additional Information 4:  0a9e372d3b4ad19135b953a78882e789 Any clues?

#2 Chris Walker

Chris Walker

    Secret Labs Staff

  • Moderators
  • 7767 posts
  • LocationNew York, NY

Posted 18 October 2013 - 09:04 PM   Best Answer

Hi mlsomers, Did you install the Netduino 4.3 SDK Beta? Chris

#3 mlsomers



  • Members
  • PipPip
  • 10 posts

Posted 19 October 2013 - 12:53 PM

Hi Chris,


Yes, but I hadn't uninstalled the previous ones (had 4.1 and 4.2 installed).

After uninstalling those and then doing a "repair" install of 4.3Beta and VS2012 I got it working again.



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.