Netduino home hardware projects downloads community

Jump to content


The Netduino forums have been replaced by new forums at community.wildernesslabs.co. This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

caEstrada's Content

There have been 9 items by caEstrada (Search limited from 09-April 19)


By content type

See this member's

Sort by                Order  

#58791 Netduino Plus 2 Firmware v4.3.1

Posted by caEstrada on 19 June 2014 - 09:31 PM in Netduino Plus 2 (and Netduino Plus 1)

Chris,

 

I can see the board with MFDeploy.  The board is NOT in bootloader mode.  The USB drivers work very well.

 

I can remember Netduino Plus was upgraded using a procedure thru MFDeploy...can I use that procedure with new firmware files and this new board?




#58804 Netduino Plus 2 Firmware v4.3.1

Posted by caEstrada on 20 June 2014 - 03:49 PM in Netduino Plus 2 (and Netduino Plus 1)

Thanks Chris, I will try that and I will let you know...thanks again




#58805 Netduino Plus 2 Firmware v4.3.1

Posted by caEstrada on 20 June 2014 - 04:29 PM in Netduino Plus 2 (and Netduino Plus 1)

Chris,

 

Already found the problem: BootLoader USB Driver was not updated, was installed but not updated on my computer.  I just click to update using the ST Microeletronics Directory under C:Applications and ready.

 

This new version do not work with VS2010 but VS2012...

 

Thanks for the great support and all the suggestions...




#58790 Netduino Plus 2 Firmware v4.3.1

Posted by caEstrada on 19 June 2014 - 09:01 PM in Netduino Plus 2 (and Netduino Plus 1)

Chris,

 

Same result, installed and restarted windows7.  What am I doing wrong?

 

Ok, disconnect the board.  Press button and keep it pressed while connecting USB to computer.  Run NetduinoUpdate...but no activity, just the OS sound like we have a new board connected but not knowing what to do...

 

I have the REV A-....both, white and blue are ON, is bootloader mode, right?




#58784 Netduino Plus 2 Firmware v4.3.1

Posted by caEstrada on 19 June 2014 - 04:28 PM in Netduino Plus 2 (and Netduino Plus 1)

Chris,

 

Thanks for addressing this.

 

Nothing shows up in MFDeploy and DFUSE.  When I connect the usb while pressing the button, the PC makes the typical sound that drivers are not installed for this board-mode and Win7 does not recognize the board (in bootloader mode).

 

However, when I connect usb in normal fashion, it works great (version 4.2 and VS2010), pretty stable, no issues.

 

Perhaps I used wrong link to get proper ST DFU tools...where are the latest.

 

Suggestions?

 

Thanks!!




#58766 Netduino Plus 2 Firmware v4.3.1

Posted by caEstrada on 18 June 2014 - 06:18 PM in Netduino Plus 2 (and Netduino Plus 1)

Hi everybody,

 

When I try to upgrade the firmware, the Netduino Plus2 I have just does:

 

1. When connect USB, makes the typical sound of Not known artifact

1b.  I cannot see anything listed in NedtuinoUpdate

2. The DFU already installed

3. The Netduino Plus 2 has both white and blue leds ON

4. When I detach and attach againg, the Netduino Plus 2 works fine (with version 4.2)

 

Suggestions?

 

I have previous version 4.2 and seems to work great with VS2010.  But I am having analog pins problems and I am not sure if related to firmware or not...

 

Suggetions?  Thanks




#51180 Netduino Plus 2 and Communication with Windows Forms

Posted by caEstrada on 07 July 2013 - 09:38 PM in Netduino Plus 2 (and Netduino Plus 1)

Zemuss,

 

I used ethernet all the time.  It provides longer distances and probably faster speeds.  I have used

ethernet in an industrial environment with excelent results.




#58764 Analog input problem

Posted by caEstrada on 18 June 2014 - 03:52 PM in Netduino Plus 2 (and Netduino Plus 1)

Hi there,

 

I just bought some Netduino Plus 2, firmware 4.2, works well with VS2010.

 

Question:  what is wrong with this

 

AnalogInput input = new AnalogInput(AnalogChannels.ANALOG_PIN_A0)

 

I am trying to read a voltage in the range 0-3.3VDC at A0...

 

The VS2010 compiler says:

 

Error    2    The best overloaded method match for 'SecretLabs.NETMF.Hardware.AnalogInput.AnalogInput(Microsoft.SPOT.Hardware.Cpu.Pin)' has some invalid arguments    C:\Users\caestradalaptop\Documents\Visual Studio 2010\Projects\ceCSharpNetduinoPlus2\ceCSharpNetduinoPlus2\Program.cs    23    21    ceCSharpNetduinoPlus2

 

Also, it is supposed I can jump the pin 3V3 to A0 and see 4095 counts, right?
 

 

Suggestions?  Thanks in advance!

 

 

 

 




#51391 Cheap + Good Cases / Enclosures - Continuing to Beat on this Topic

Posted by caEstrada on 13 July 2013 - 01:39 AM in General Discussion

Chuckles,

 

I have used this

 

 

which resembles a PLC form factor.  You can buy it from straitway.com.mx....they

already have a board where you can mount your Netduino.  That board includes

the terminal screws to receive external signals.  That board already is perforated.

 

 

let me know if I can help.





home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.