Netduino home hardware projects downloads community

Jump to content

The Netduino forums have been replaced by new forums at This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

So far dissapointed

  • Please log in to reply
5 replies to this topic

#1 Wayneio



  • Members
  • PipPip
  • 24 posts

Posted 19 April 2013 - 09:28 AM

So my first day with the Netduino hasn't gone as well as I had hoped.


Firstly there was the difficulty in getting it to actually be detected by VS2012


Then eventually, it worked, where it started to blink the leds...


so then I try another simple application to control it via the button, and i either get the error message in that post above, "the device is not in an initilised state" or "Error  1  Unable to communicate with device USB:Netduino"


So at the moment, I cant even get the most simple test applicator to deploy properly. I've tried various USB ports. Windows does detect the netduino fine.

#2 LordOfTheFlakes



  • Members
  • PipPip
  • 25 posts

Posted 19 April 2013 - 10:10 AM

Hi, did you use Visual Studio 2010 or 2012? I also had many problems but they were all fixed with help from this great community ;)


EDIT: If you use 2012, please download 2010 and try again. Most times you have to find the right moment to plug the netduino in and press Run in Visual Studio. Otherwise you get some "Hardware-Errors". In that case plugging in and out helps every time ...

Please correct my wrong English! ;)

#3 tim c

tim c

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts

Posted 19 April 2013 - 12:13 PM

I had a few similar issues and even had to reinstall the firmware when I somehow locked up the device.


If you reboot both your PC and the Netduino and still see the error I suggest checking out these 2 posts on how to load the firmware:





#4 Wayneio



  • Members
  • PipPip
  • 24 posts

Posted 19 April 2013 - 12:56 PM



I have ensured that .netMF 4.3 is installed, have followed the guide to install firmware 4.3 on the netduino plus 2.


However, when i press debug it still says "target is not in initilized state, rebooting..." then says ready in blue (but not debugging) and some of the time the code has worked on the netduino, other times it hasnt, but it's never in debug mode.


Or it often says "Unable to communicate with device USB:Netduino" or "Device not found or cannot be opened - USB:Netduino  "  

#5 Wayneio



  • Members
  • PipPip
  • 24 posts

Posted 19 April 2013 - 02:02 PM

If it helps, the rare occassion that it does say "ready" and appear to be in debug mode, pressing the button causes the netduino to disconnect (and disappear from devices) then releasing the button makes it appear again.

#6 Chris Walker

Chris Walker

    Secret Labs Staff

  • Moderators
  • 7767 posts
  • LocationNew York, NY

Posted 19 April 2013 - 04:32 PM

Hi Wayneio, Sorry for the troubles. If you're just getting started with Netduino, I would recommend using the 4.2 firmware rather than starting out with the 4.3 beta. And using Visual C# 2010 Express. It's possible to use VS2012 with .NET MF 4.2 (using the .NET MF 4.3 SDK). And to use the 4.3 beta firmware. But both of those scenarios should be considered beta. So in the interest of making sure you have a good experience...I would recommend starting out with the production release (VS2010, .NET MF 4.2 QFE2 SDK, Netduino 4.2 SDK). Of course we're happy to help diagnose the issues you're having with the beta. We want to get those fixed for RTM. [As a side note I'm out today but will be back on Monday and can assist.] Chris

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.