Netduino home hardware projects downloads community

Jump to content


The Netduino forums have been replaced by new forums at community.wildernesslabs.co. This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.
Photo

Netduino Plus / Windows 10 / VS2015


  • Please log in to reply
3 replies to this topic

#1 BrianG

BrianG

    New Member

  • Members
  • Pip
  • 4 posts

Posted 18 October 2016 - 05:30 PM

Hi Folks,

 

I was using the early Netduino Plus a couple of years back and I am just getting back into it. I am trying to get it up and running under the following configuration:-

 

Windows 10

Visual Studio 2015

Netduino Plus

.NET Framework 4.5.2

Netduino Legacy Templates

 

I get the following from the deployment tool:-

TinyCLR
HalSystemInfo.halVersion:               4.1.2821.0
HalSystemInfo.halVendorInfo:            Netduino Plus by Secret Labs LLC

SoftwareVersion.BuildDate:              Feb 14 2011

SoftwareVersion.CompilerVersion:        400902

Needless to say none of my old projects from VS2010 will load and when I recreate them I they will not deploy.

 

I think I need to upgrade the firmware on the Netduino Plus but I am not certain to which version and where to get the upgrade from.

 

Any help or suggestions would be gratefully received.

 

Thanks

 

 



#2 BrianG

BrianG

    New Member

  • Members
  • Pip
  • 4 posts

Posted 19 October 2016 - 01:00 PM

I was looking at this post:-

                http://www.0x00.to/p...2015-windows-10

and followed the instructions with MFDeploy tool to get the above info. I then tried to follow it to upgrade the firmware using this post:-

?                http://forums.netdui...-firmware-v420/

 

Having reset the netduino (3.3v wire to the reset sq at the bottom of digital I/O zero) I cannot get anything to recognize it, including MFDeploy.

 

I downloaded a version of the SAM-BA 2.16 from here:-

                 http://www.atmel.com...PROGRAMMER.aspx

This looks like it is finding the board on \USBserial\COM4

 

At this point I have to select a board eg at91cap9-dk_mem18 or at91sam7s64-ek or samd20_xplained_pro[not factory programmed]. I found this set of posts

                 http://forums.netdui...hing-42-failed/

and it mentions in here to use - at91sam7x512-ek but this is for a netduino mini and gives errors

 

I noticed in another post that they were seeing the device in device manager as "AT91xxx" and I was not seeing this. What I had to do was

  1. open computer management
  2. select device manager
  3. right click on device manger and select "show hidden icons"
  4. open up the USB controller section

and the netduino was listed twice as "Netduino"



#3 David Weaver

David Weaver

    Advanced Member

  • Members
  • PipPipPip
  • 50 posts
  • LocationBloomington IL

Posted 22 October 2016 - 01:20 PM

Brian,

 

This sounds like a nightmare.  I am not an expert but Ill try to get you up and running.

 

First I thank 4.5 is a Windows .net version not Micro Frameworks?

 

I have heard Visual Studio 2015 is not ready for prime time try using VS2013 express.

 

The latest stable Micro Framework version is 4.3. But my experience has shown 4.2 works just as well for most applications. 

 

Start you application as a .net framework console application. Then select the libraries from the directories where they exist.

 

C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.3

C:\Program Files (x86)\Secret Labs\Netduino SDK\Assemblies\v4.3

 

For 4.2 use these directories:

 

C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2

C:\Program Files (x86)\Secret Labs\Netduino SDK\Assemblies\v4.2

 

I hope this helps,

 

David Weaver



#4 Jason.Net

Jason.Net

    Advanced Member

  • Members
  • PipPipPip
  • 41 posts

Posted 03 December 2016 - 12:36 PM

HI

I have been using VS2015 for over a year on the Netduino 2+ without a problem. There are posts on here that cover setting it up but this is from my notes.

 

Install MicroFrameworkSDK.MSI (4.3 SDK-QFE2)
Install netduinosdk.exe (4.3.2 May 2015)
Install VS plugin - right one for the version in use (netmfvs14.vsix)
Update firmware on device using updater

 

See my post on issues I found and solved here

http://forums.netdui...some-solutions/






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.