Netduino home hardware projects downloads community

Jump to content

The Netduino forums have been replaced by new forums at This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

UDP support in MF 4.3.


  • Please log in to reply
2 replies to this topic

#1 ukkiwisurfer


    Advanced Member

  • Members
  • PipPipPip
  • 32 posts
  • LocationLondon

Posted 23 January 2015 - 11:05 PM



Has anyone had any luck with UDP on a Netduino Plus 2 with MF 4.3.1? I seem to get errors when using the SetSocketOption call. The exception returns an internal error id of 10042 (Bad protocol option).


I'm starting to wonder whether using the Netduino boards are worth it (given this sort of issue and other bugs - like the network stack not detecting ethernet plug disconnects). I've noticed that someone has tried this on another MF board and it worked fine. Any suggestions?


I'm trying to capture UDP messages broadcast by another device on the local network.


        /// <summary>

        /// Starts the client connection.

        /// </summary>

        public void Open()


            m_IsOpen = false;

            lock (m_SyncLock)


                var ipAddress = IPAddress.Parse("");

                var ipBytes = ipAddress.GetAddressBytes();


                m_Client.SetSocketOption(SocketOptionLevel.IP, SocketOptionName.MulticastInterface, ipBytes);



                m_IsOpen = true;



#2 Chris Walker

Chris Walker

    Secret Labs Staff

  • Moderators
  • 7767 posts
  • LocationNew York, NY

Posted 24 January 2015 - 08:07 AM

Hi ukkiwisurfer,

It may be multicast that's an issue here, rather than UDP.

If you drop the multicast option, can you create a socket alright?

BTW, we're working on a shiny new networking stack for .NET Micro Framework. More info here:

We'd love your help testing out the new stack over the next few months as we publish progressive builds.

Welcome to the Netduino community,


#3 ukkiwisurfer


    Advanced Member

  • Members
  • PipPipPip
  • 32 posts
  • LocationLondon

Posted 24 January 2015 - 08:48 AM

Hi Chris,


My apologies for the lack of clarification -it is multicast that seems to be the problem. The nature of your reply seems to confirm that UDP multicast is not currently supported with the existing IP stack. Is that correct?


I'd like to help with testing on the new IP stack; however the existing issue does pose a challenge. If I read your new IP rollout correctly, 12 weeks from now we should have a new stack, feeding into a beta programme. I can't really afford to wait 12 weeks to resolve this existing issue, blocking development in the process. I've already lost a week trying to resolve issues around the existing IP stack (which thankfully your 4.3.1 firmware partially resolved).


I'm also concerned about the lack of clarity on what features in the MF are not supported by the firmware (or have issues). Do you have a defect list, by firmware version, that identifies issues, severity, status and timeframes to resolve?


I'm hoping to soon be in a state to release the framework I've built out for MF, which may be of use to others. Nothing fancy: multi-threaded services (not web services), logging support for AMQP and MQTT providers, basic assertions, and a standardised set of error classifications. The aim is to support integrating with a server side framework I've built up around WCF. 


Finally, thanks for the welcome!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.