Netduino home hardware projects downloads community

Jump to content

The Netduino forums have been replaced by new forums at This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

Serial Communication Problems

serial netduinoplus2 netduinoplus ttl FTDI

  • Please log in to reply
3 replies to this topic

#1 georgiaredhead2002


    New Member

  • Members
  • Pip
  • 2 posts

Posted 08 April 2014 - 07:01 PM

Hello everyone,


I am very new at programming in C# so I may be a bit behind in the times. I come from the ladder logic world of PLC's. I am excited to use this platform to enhance my knowledge and build some incredible stuff, but first...


I can not seem to communicate via serial communication. I hope that someone here can give me some insight. The assemblies download the form loads and I set breakpoints to see if I get anywhere and the Netduinos never seem to read the info. We tried several methods and various ideas but to no avail. Once I get this problem tackled, the stars are the limit. It's frustrating when you have ideas and huge roadblocks keep happening. His works he pushes on, I stumbled and fell. Help me be the tortoise in this race and kick butt.


Here are my specs:


Both a Netduino Plus 1 and 2


Windows 8.1 Updated Today


Visual Studios 2013 Pro


I have tried all of the following. SDK and updated firmware. versions 4.1, 4.2, 4.3 and beta versions for VS2013.

Yes, uninstalled restart and reinstalled three times a piece.


FTDI drivers found here...




I used this websites code for testing and instructions...




I have a colleague who used the same code on Visual Studios 2010 and had success, but we can not seem to figure out the differences. We swapped cables but not computers.


Any suggestions would be greatly appreciated. Thank you and have a great day.



Attached Files

#2 dino4net


    Advanced Member

  • Members
  • PipPipPip
  • 40 posts

Posted 09 April 2014 - 10:32 AM

What serial communication do you have, a RS232 to a computer?
Then you need something like this: http://www.exp-tech....TTL-3-5-5V.html

#3 georgiaredhead2002


    New Member

  • Members
  • Pip
  • 2 posts

Posted 09 April 2014 - 03:40 PM

I am using a standard USB cable with FTDI's FT232 chip in it. It's the one all the people on this forum use. That's why I chose it. <--- Drivers installed from FTDI's website.


Window's generic Prolific USB driver would not start but on my colleagues computer he never even installed the FTDI driver.


The only difference is I'm running VS2013 and the FTDI driver. He is on VS2010 and Windows 7.


I thought someone on here would have had some experience and success with Windows 8.1 and VS2013 using this chipset and driver. Hopefully they will come along soon enough...fingers crossed.


I have a massive amount of code written and now I'm trying to add serial communication and a Windows form app. I would hate to revert back to 2010 Express.

#4 Chris Walker

Chris Walker

    Secret Labs Staff

  • Moderators
  • 7767 posts
  • LocationNew York, NY

Posted 22 April 2014 - 11:53 AM

Hi georgiaredhead2002,

I would recommend starting with Teraterm/HyperTerminal to test the serial communication between your computer and the Netduino. Make sure that works first. sounds like you've already done this, but please double-check that TX and RX are wired up the right way to your Netduino. And make sure that the GND connection from your FTDI cable is also plugged into one of the Netduino's GND pins.


Also tagged with one or more of these keywords: serial, netduinoplus2, netduinoplus, ttl, FTDI

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.