Netduino home hardware projects downloads community

Jump to content


The Netduino forums have been replaced by new forums at community.wildernesslabs.co. This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

Easter's Content

There have been 5 items by Easter (Search limited from 29-January 20)


By content type

See this member's

Sort by                Order  

#20489 Shield Recommendations

Posted by Easter on 11 November 2011 - 04:29 PM in Netduino 2 (and Netduino 1)

The adafruit shield should work well. it can handle 4 motors (or two steppers) and still handle two servos. The main thing I'd watch for is pin usage between the motor shield and your wifi. I'm not sure about that.



#10994 Netduino & PHP communication

Posted by Easter on 16 March 2011 - 05:37 PM in Netduino 2 (and Netduino 1)

Hi,
I'm new to the Netduino and I'm starting a small project. I'm programming some LEDs in Visual Studio with a dim function. This all works very well. Now I want to make a website in PHP that will send data to the .NET program on the Netduino. So I can remote-access the LEDS and dim them.

I wonder how I can send data via php to the Netduino and handle it. Hope someone can help me out with this,


Take care,


Are you using a Netduino or a Netduino Plus?



#10596 Experimental WIZnet Driver - klotz MyFirstWebPage Example

Posted by Easter on 05 March 2011 - 05:08 PM in Netduino 2 (and Netduino 1)

In Visual Studio, remove the FEZ assemblies such as FEZPanda_GHIElectronics.NETMF.FEZ from your references, and the error will go away


Ah, perfect - it works great. Thanks for bearing with me.



#10589 Experimental WIZnet Driver - klotz MyFirstWebPage Example

Posted by Easter on 05 March 2011 - 03:33 PM in Netduino 2 (and Netduino 1)

Thanks for the reply, this got me a step closer. Setting the correct startup application then produced this error:

An unhandled exception of type 'System.InvalidOperationException' occurred in FEZPanda_GHIElectronics.NETMF.FEZ.dll

Additional information: FEZ Panda not detected!

In troubleshooting, I replaced the wiznet instantiation with one of Klotz's commented out ones.

Replacing:
CKlotzManDo.NETMF.Net.Wiznet5100 wiznet = new CKlotzManDo.NETMF.Net.Wiznet5100(SPI.SPI_module.SPI1, (Cpu.Pin)FEZ_Pin.Digital.Di10);

With:
CKlotzManDo.NETMF.Net.Wiznet5100 wiznet = new CKlotzManDo.NETMF.Net.Wiznet5100(SPI.SPI_module.SPI1, Pins.GPIO_PIN_D10);

This still produces the same "FEX Panda not detected!" error, but unlike the with old line, I can continue and deployment completes. The listening port functions and serves the webpage. Success!

Moving forward, I did have to change the code further as mentioned here in order to get it to connect more than once.

So I'm up and running, though I'd be interested if anyone has thoughts on the FEZ Panda error.



#10519 Experimental WIZnet Driver - klotz MyFirstWebPage Example

Posted by Easter on 03 March 2011 - 03:33 PM in Netduino 2 (and Netduino 1)

Netduino + WIZnet Shield - My First Webpage Example

I'm trying to run this example from klotz, but building errors with: Error 1 Program 'C:\Users\lenovo\Documents\Visual Studio 2010\Projects\Wiznet5100v2\obj\Debug\Klotz.NETMF.Net.Wiznet5100.exe' does not contain a static 'Main' method suitable for an entry point CKlotzManDo.NETMF.Net.Wiznet5100

Any ideas where I'm going wrong? Sorry if this is more of a general noob question than netduino specific one.




home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.