Netduino home hardware projects downloads community

Jump to content

The Netduino forums have been replaced by new forums at This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

BanksySan's Content

There have been 3 items by BanksySan (Search limited from 30-November 21)

By content type

See this member's

Sort by                Order  

#65071 Cannot deploy to old Netduino Plus

Posted by BanksySan on 04 April 2016 - 12:39 PM in Netduino 2 (and Netduino 1)

Thanks Nevyn,


I guess this is the one I should be using?  http://forums.netdui...-v420-update-1/


However, I'm still getting troubles.


When I go to Device Capabilities on MFDeploy, it just says `Not Supported`.


I tried deploying anyway, I get through the config deployment but fail with an error dialogue box.


.NET Micro Framework Deployment Tool
Error: Unable to deploy to device

#65066 Cannot deploy to old Netduino Plus

Posted by BanksySan on 03 April 2016 - 08:25 PM in Netduino 2 (and Netduino 1)

I've got a bit further.  I was plugging in via a USB hub, plugging directly into the PC gets me further.  Now when I ping I get

Pinging... TinyCLR
Which I seem to remember is a good thing.


Now when I run via Visual Studio I get:


Found debugger!

Create TS.

 Loading start at 14d324, end 162e8c

Attaching file.

Assembly: mscorlib (4.1.2821.0) (3880 RAM - 33236 ROM - 19134 METADATA)

Attaching file.

Assembly: Microsoft.SPOT.Native (4.1.2821.0) (1144 RAM - 6516 ROM - 4479 METADATA)

Attaching file.

Assembly: Microsoft.SPOT.Hardware (4.1.2821.0) (1752 RAM - 11440 ROM - 7371 METADATA)

Attaching file.

Assembly: Microsoft.SPOT.Net (4.1.2821.0) (704 RAM - 5060 ROM - 2452 METADATA)

Attaching file.

Assembly: System (4.1.2821.0) (872 RAM - 5992 ROM - 3206 METADATA)

Attaching file.

Assembly: Microsoft.SPOT.IO (4.1.2821.0) (740 RAM - 4620 ROM - 2522 METADATA)

Attaching file.

Assembly: System.IO (4.1.2821.0) (1548 RAM - 13292 ROM - 5862 METADATA)

Attaching file.

Assembly: Microsoft.SPOT.Hardware.SerialPort (4.1.2821.0) (512 RAM - 3488 ROM - 1543 METADATA)

Attaching file.

Assembly: Microsoft.SPOT.Hardware.Usb (4.1.2821.0) (580 RAM - 3740 ROM - 1844 METADATA)

Attaching file.

Assembly: SecretLabs.NETMF.Hardware ( (256 RAM - 1108 ROM - 491 METADATA)

Attaching file.

Assembly: SecretLabs.NETMF.Diagnostics ( (180 RAM - 440 ROM - 166 METADATA)

Loading Deployment Assemblies.

Attaching deployed file.

Assembly: SecretLabs.NETMF.Hardware.Netduino ( (268 RAM - 796 ROM - 423 METADATA)

Attaching deployed file.

Assembly: NetduinoApplication1 ( (196 RAM - 388 ROM - 175 METADATA)

Attaching deployed file.

Assembly: GoBus ( (540 RAM - 4016 ROM - 1631 METADATA)


Link failure: some assembly references cannot be resolved!!

Assembly: GoBus ( needs assembly 'mscorlib' (

Assembly: GoBus ( needs assembly 'Microsoft.SPOT.Hardware' (

Assembly: GoBus ( needs assembly 'Microsoft.SPOT.Native' (

Error: a3000000

Waiting for debug commands...

The program '[4] Micro Framework application: Managed' has exited with code 0 (0x0).

So... still can't run anything but I think it's a step in the right direction.

#65065 Cannot deploy to old Netduino Plus

Posted by BanksySan on 03 April 2016 - 05:57 PM in Netduino 2 (and Netduino 1)

I have a pretty old Netduino Plus.


I've just got it out and dusted it off, installed the prerequisites on my new Windows 10 machine but now I can't deploy to it.


When I ping with MFDeploy I get:

Pinging... Found debugger!
Create TS.
 Loading start at 14d324, end 162e8c

If I select Device Configuration it just returns:  

Not Supported

I suspect I have some out of date firmware.    Maybe the Micro Framework has incremented a bit since I was last playing with it.


I've tried following the instructions here: http://forums.netdui...-firmware-v431/


The update tool doesn't see my device at all, and I can't figure out what I'm supposed to to (if anything) with the STDFY_Drivers that's linked to.


Any help?





home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.