Netduino home hardware projects downloads community

Jump to content

The Netduino forums have been replaced by new forums at This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

How to upgrade to the .NET Micro Framework v4.3 SDK

  • Please log in to reply
25 replies to this topic

#21 dmr6124


    New Member

  • Members
  • Pip
  • 6 posts

Posted 18 April 2013 - 02:05 PM

I've attached a Word Doc with the screen shot from my desktop showing both the Vs Express 2012 for Windows Desktop screen, with the NETMF 4.3 installation and error windows superimposed.Attached File  NETMF 4.3 Error.doc   1.89MB   12 downloads BTW, I did an installation on my laptop too. Same products, but it worked on my laptop.

#22 Odelay


    New Member

  • Members
  • Pip
  • 1 posts

Posted 14 June 2013 - 01:50 PM

dmr6124: did found a solution for this error? I'm having te same error and express 2012 installed?

#23 jkrarup


    New Member

  • Members
  • Pip
  • 8 posts

Posted 16 July 2013 - 05:19 PM

Any reason that you haven't included 4.3 MF and SDK on your "Downloads" page for those of us who have completely switched to VS 2012?

This way we don't have to browse the Forum in order to discover that there is a version for those on the cutting edge.





#24 Paolo Patierno

Paolo Patierno

    Advanced Member

  • Members
  • PipPipPip
  • 169 posts
  • LocationItaly

Posted 25 July 2013 - 03:53 PM

I have updated my project on CodePlex to .Net Micro Framework 4.3 !


uPLibrary - .Net Micro Framework Helper Library


M2M communication MQTT Client Library


.Net Micro Framework Weather Station



Paolo Patierno

Microsoft MVP on Windows Embedded & IoT

Azure Advisor

Twitter : @ppatierno
Linkedin : paolopatierno
Blog : DevExperience

Blog : Embedded101

#25 SawDust


    New Member

  • Members
  • Pip
  • 2 posts

Posted 06 June 2014 - 01:30 AM

Hello Forum,

I am new to micro controllers and .NET so I am still in the steep slope of the learning curve. I have completed the simple examples and am now experimenting with talking to other devices (that is the point afterall!). I have a serial LCD working and of course solenoids. However I am having trouble with I2C devices so I decided to try the drivers in the MicroFramework Toolbox (thanks Stefan, very nice!), and started with the DS1307 clock example. The toolbox example program crashed immediately and the messages hint at a software version issue (?).


I have a Netduino 2 Plus, using the following software:

Visual Studio Express 2012 (v11.0.50727.42)

.NET MicroFramework SDK 4.3 (QFE1) (v4.3.1.0)

Netduino SDK v4.3.1 (Feb 2014) (v4.3.1.0)

.NET MicroFramework Toolbox (v0.1.0.0)


I attached a pdf containing a program listing, messages during Deployment, Build, and Debug, and a snapshot of the external references used. I would appreciate any help from an experienced user.



Attached File  RTC_test.pdf   176.94KB   7 downloads


6/17/2014 Update

I found an answer to my question elsewhere on this forum, downloaded Toolbox compatible with 4.3. Happy camper now with the exception of some Visual Studio 12 stability issues.

#26 blackt1ger



  • Members
  • PipPip
  • 14 posts

Posted 16 November 2014 - 10:32 PM



Using Netduino Plus 2.


Okay, I got Visual Studio 2013 and Visual Studio 2013 Express for Desktops.  I managed to get everything installed.  Updated the firmware with the Netduino update.  Everything looks okay.


Project builds and deploys, but when I want to debug, it reboots the Netduino, and then tries to re-attach the debugger.  It fails.  Subsequent attempts to deploy fails.  Need to remove/insert USB wait for it to detect and I can deploy again, but the same error happens when I try to debug.


I erased the app (using the Netduino Update options dialog), but it doesn't make any difference.


Just to be clear, the MF experimental is no longer needed, right?  CodePlex has the MF 4.3 - R2-Beta which supports Visual Studio 2013.  But what about the Netduino SDK ? Do we use the experimental version as linked in the beginning of this forum?


Looking for a device on transport 'USB'
Starting device deployment...
Iteration 0
Opening port \\?\USB#VID_22B1&PID_1000#000000000000#{09343630-a794-10ef-334f-82ea332c49f3}\Operations
Attaching debugger engine...
... debugger engine attached!
Querying device assemblies...
Found Assembly mscorlib
Found Assembly Microsoft.SPOT.Native
Found Assembly Microsoft.SPOT.Hardware
Found Assembly Microsoft.SPOT.Net
Found Assembly System
Found Assembly Microsoft.SPOT.Hardware.SerialPort
Found Assembly Microsoft.SPOT.IO
Found Assembly System.IO
Found Assembly Microsoft.SPOT.Hardware.PWM
Found Assembly Microsoft.SPOT.Hardware.Usb
Found Assembly SecretLabs.NETMF.Diagnostics
Found Assembly SecretLabs.NETMF.Hardware.Netduino
Found Assembly Microsoft.SPOT.Hardware.OneWire
Found Assembly Microsoft.SPOT.Time
Found Assembly SecretLabs.NETMF.Hardware.NetduinoPlus
Found Assembly SecretLabs.NETMF.Hardware.NetduinoMini
Found Assembly NetduinoApplication1
Found Assembly SecretLabs.NETMF.Hardware.PWM
Found Assembly SecretLabs.NETMF.IO
Found Assembly SecretLabs.NETMF.Hardware.AnalogInput
Found Assembly SecretLabs.NETMF.Hardware
Adding pe file C:\Program Files (x86)\Secret Labs\Netduino SDK\Assemblies\v4.3\le\ to deployment bundle
Adding pe file C:\Program Files (x86)\Secret Labs\Netduino SDK\Assemblies\v4.3\le\ to deployment bundle
Adding pe file C:\dev\TigerTools\Hardware Tools\NetduinoApplication1\NetduinoApplication1\bin\Debug\le\ to deployment bundle
Adding pe file C:\Program Files (x86)\Secret Labs\Netduino SDK\Assemblies\v4.3\le\ to deployment bundle
Adding pe file C:\Program Files (x86)\Secret Labs\Netduino SDK\Assemblies\v4.3\le\ to deployment bundle
Adding pe file C:\Program Files (x86)\Secret Labs\Netduino SDK\Assemblies\v4.3\le\ to deployment bundle
Adding pe file C:\Program Files (x86)\Secret Labs\Netduino SDK\Assemblies\v4.3\le\ to deployment bundle
Attempting deployment...
Incrementally deploying assemblies to device
All assemblies on the device are up to date.  No assembly deployment was necessary.
Assemblies successfully deployed to device.
Restarting interpreter...
Attaching to device...
Waiting for device to initialize...
The debugging target and the debugger engine failed to initialize because of unspecified device errors.
The debugger engine thread has terminated unexpectedly with error 'Object reference not set to an instance of an object.'.

Edited by blackt1ger, 16 November 2014 - 10:57 PM.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.