Netduino home hardware projects downloads community

Jump to content


Photo

MFDeploy on Netduino 2 FW 4.3.1: cannot deploy! [RESOLVED]

MFDeploy 4.3.1

  • Please log in to reply
2 replies to this topic

#1 energywave

energywave

    New Member

  • Members
  • Pip
  • 7 posts

Posted 22 April 2015 - 10:19 AM

Hello to all,

Some lines to present myself:

I'm new to netduino but I'm an experienced full .net and Compact Framework developer from Italy, used to work with API from .net (so using much "low level" programming, if we may call "low level" something inside .net code  :rolleyes: )

 

I've developed my first, production program for netduino 2, updated with 4.3.1 firmware using 4.3 QFE2 MF SDK.

Very flawless experience, I could get it done in a workday!

 

My program is a digital I/O remoter: I'll connect netduino 2 to a Panel PC's RS232 (using netduino COM4, to not eat two digital I/O) and I'll read and write I/O from the panel PC, using a simple and documented protocol I've created (in the same workday).

 

I've even created a watchdog thread on my netduino program that will reset device if the main thread is locked (not the perfect solution but as we can't use the real watchdog it's better than nothing)

All is managed with interrupts and spontaneous sends on RS232 so that from the panel pc software I don't have to poll for input pin changes.

 

This is working VERY NICELY, and I'm astonished I could do it in a workday!

 

Now to the point:

using Visual Studio I can deploy without problems, press F5 and there we are. Now I have to pass the software to our company people that will prepare 20 netduino2 for a customer, so I was guessing to use MFDeploy for that. I've correctly created the .hex file so to pass the hex file to the people who will prepare the boards, they'll have only to deploy the .hex file to the 20 netduino2.

 

But I cannoy get MFDeploy to deploy anything! I correctly see netduino, I can ping it (reply is from TinyCLR) but pressing the Deploy button an error stating "Error: No response from device" is shown.
(see attached screenshot)

 
Furthermore, as soon as the error message is shown, my program on netduino stops working (I'm flashing the led every 2 seconds and after the message no more flashing :( )

 

I'm I missing something? Should I deploy all 20 boards with Visual Studio "F5"...? Is there some incompatibilities with 4.3.1 firmware? Please help me...

 

EDIT: Using MFDeploy from 4.2 SDK I'll go a step further but then MFDeploy is complaining about .sig file. Please check attached file:

MFDeploy 4.2 Error.PNG

 

EDIT 2: Searching and searching anywhere about it I've found an old Chris reply about ignoring signature chack failing, unplug and replug the device that it should work ok. I did it and... that's true!

 

RESUME TO GET A WORKING SOLUTION:

If you have 4.3.1 firmware on the N2 and 4.3.x SDK installed MFDeploy will not work. You have to install MFDeploy from 4.2 SDK (personally I've installed the old SDK on a colleague PC to not mess my SDK and copied only the folder C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.2\Tools (C:\Program Files\Microsoft .NET Micro Framework\v4.2\Tools on 32bit machines) from the PC where I've installed the 4.2 SDK to mine. You'll find that folder as already existant, that's ok but don't overwrite existing files.

Now you have MFDeploy 4.3 in the 4.3\Tools folder and MFDeploy 4.2 in the 4.2\Tools folder. Use 4.2 MFDeploy to create and deploy the .hex file and when it's complaining about .sig file just ignore the message, in reality all was correctly done. Just unplug the device (to turn it off) and replug it. Your program will start.

 

 

Thank you in advance,

Henrik Sozzi

Attached Files



#2 Chris Walker

Chris Walker

    Secret Labs Staff

  • Moderators
  • 7767 posts
  • LocationNew York, NY

Posted 23 April 2015 - 04:55 AM

Hi Henrik,

Are you using MFDeploy from the 4.3.1 SDK? If so, you may want to grab a copy of MFDeploy from the 4.2 SDK and try deploying with that. I know it sounds odd...but there are some timing changes in the new SDK which could potentially cause issues like this.

Also...if you connect to device using F5 from MFDeploy first, does that help it deploy?

Welcome to the Netduino community, and thanks for sharing your experiences with us!

Chris

#3 energywave

energywave

    New Member

  • Members
  • Pip
  • 7 posts

Posted 23 April 2015 - 10:46 AM

Thank you Chris for your fast reply,

I've updated my first post. I've tried MFDeploy from SDK 4.2 and effectively I'm going a step further. Now it seems to do what is expected but at last an error is shown complaining about .sig file (please see first post's attached file)

I've tried recreating the hex file with MFDeploy 4.2 with and without the key file: very same result.

I'm out of options...

 

Henrik







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.