Netduino home hardware projects downloads community

Jump to content


Photo

Beta: Visual Studio 2013 support


  • Please log in to reply
80 replies to this topic

#81 mv10

mv10

    New Member

  • Members
  • Pip
  • 6 posts

Posted 13 March 2015 - 05:04 PM

We had an old Netduino Plus v1 kit on the shelf that we finally opened up to play around with. While trying to get it to work with VS2013, we kept running into the "missing project subtype" error which has been mentioned a few times here.

 

It appears the issue is that the SDK installs the Netduino templates into a VS2010 folder. Check your Documents folder for a VS2010 Templates folder, and copy the contents to your VS2013 folder and the problem should go away.

 

For the record, the best out-of-the-box steps for a v1 are:

 

1. update the bootloader and install the 4.2 firmware

http://wiki.netduino...ep-by-step.ashx

 

2. install the latest .NET Micro Framework SDK:

http://netmf.codeple...ses/view/133285

 

3. install the VS2013 .NET Micro Framework Project System:

open VS2013, choose Tools / Extensions and Updates, choose "Online" at the left, search for ".net micro" and install

 

4. install the netduino 4.2 SDK (listed under "netduino 2" but works with our v1):

http://www.netduino.com/downloads/

 

5. move the templates as described above

 

I've done this on three machines with somewhat different configurations (Win 7 Pro x64, Win 7 Home x86, Win 8.1 x64) and these same steps now work every time. Next is to get my Plus V2 running...






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.