Netduino home hardware projects downloads community

Jump to content


The Netduino forums have been replaced by new forums at community.wildernesslabs.co. This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

tridy's Content

There have been 7 items by tridy (Search limited from 03-March 20)


By content type

See this member's

Sort by                Order  

#70776 netduino3 now works with VS2017

Posted by tridy on 08 July 2017 - 09:21 PM in General Discussion

working_driver.png

 

Yes! Now both the driver works and VS 2017 can deploy to it.

 

And I was able to create the blinking led demo from http://docs.ghielect...rials/gpio.html

 

Thanks! 

 

P.S. Since Netduino has the white power led that shows when the device is on, what do yo think about the idea of having blue led on while booting and turning it off after the boot is finished?




#70770 netduino3 now works with VS2017

Posted by tridy on 08 July 2017 - 07:36 PM in General Discussion

We can change the LED behavior to whatever we like. How it worked before in NETMF is not related ot how it is today with TinyCLR OS.

 

By the way, someone made this video with a blinking LED on netduino3 https://youtu.be/6UCjEHaMSB0

 

yes, the blinking led was sort of "hello world" application :)

 

 

I tried to connect it to 2 more computers running Windows 10 x64 (that haven't "seen" Netduino before) with the same result where it could not install drivers.

 

Is there a way to verify something via "DFU Tester" application?




#70765 netduino3 now works with VS2017

Posted by tridy on 08 July 2017 - 02:00 PM in General Discussion

I am wondering why the blue light does not go off even if I supply the power from the adapter (not USB).

If I remember right (I might be wrong), with the old firmware, it used to go off after the boot is completed.




#70744 netduino3 now works with VS2017

Posted by tridy on 08 July 2017 - 11:38 AM in General Discussion

Great news! Good job!

 

Here is my first try to get Netduino 3 WiFi to work:

 

I tried the steps on http://docs.ghielect...bootloader.html it and:

1. downloaded and installed the tools 

2. generated the file

3. started Netduino in "STM Device in DFU Mode"

4. uploaded the file (I had to run the tool "As Administrator" to get the "Upload" button enabled). (screenshots)

 

It went through OK. However when I plug in the Netduino to USB, it boots, however the blue light stays on all the time (I do not think it should). And there seems to me a problem with the driver.

 

blue_led_netduino.jpg

 

 

 

Netduino_Driver.png

 

 

- System
    - Provider
      [ Name] Microsoft-Windows-Kernel-PnP       [ Guid] {9C205A39-1250-487D-ABD7-E831C6290539}
      EventID 441       Version 0       Level 2       Task 0       Opcode 0       Keywords 0x4000000000000000     - TimeCreated
      [ SystemTime] 2017-07-08T11:07:35.796899400Z
      EventRecordID 874       Correlation     - Execution
      [ ProcessID] 4       [ ThreadID] 364
      Channel Microsoft-Windows-Kernel-PnP/Configuration       Computer ASUSG75     - Security
      [ UserID] S-1-5-18
- EventData
    DeviceInstanceId USB\VID_1B9F&PID_0110\5&87d8f66&0&3     LastDeviceInstanceId USB\VID_0666&PID_8888\00000000001A     ClassGuid {36FC9E60-C465-11CF-8056-444553540000}     LocationPath PCIROOT(0)#PCI(1400)#USBROOT(0)#USB(3)     MigrationRank 0xf000ffffffff0033     Present false     Status 0xc0000719

 

 

Where do I start with troubleshooting at this point?

 

Thanks!




#69094 Need help getting back up and running

Posted by tridy on 06 June 2017 - 10:58 PM in General Discussion

Hi.

 

I have compiled .Net Micro Framework 4.4, recompiled the Netduino SDK, copied the templates and all seems to work inside VS2017.

Now, the problem is that the device is 4.3.1.0 and I am trying to deploy 4.4.0.0.

 

Is there a way to compile a new firmware for Netduino 3 WiFi based on 4.4 Micro Framework? Is it complicated?

 

Thanks!




#69093 Visual Studio 2017 support

Posted by tridy on 06 June 2017 - 10:22 PM in Visual Studio

Ok, I managed to build

  • .Net Micro Framework 4.4
  • Netduino SDK
  • VS Templates

 

so it works to create and build a Netduino project in Visual Studio 2017.

 

However when I try to deploy to Netduino, it says:

 

Severity Code Description Project File Line Suppression State
Error Cannot deploy the base assembly 'mscorlib', or any of his satellite assemblies, to device - USB:Netduino twice. Assembly 'mscorlib' on the device has version 4.3.1.0, while the program is trying to deploy version 4.4.0.0
 
can i copy the newer files to Netduino somehow, or do I need to recompile the firmware and update? If so, any tips on how to do it?
 
thanks!



#69057 Visual Studio 2017 support

Posted by tridy on 06 June 2017 - 12:05 AM in Visual Studio

Any updates on VS2017 for Netduino support?

 

thanks





home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.