Netduino home hardware projects downloads community

Jump to content


The Netduino forums have been replaced by new forums at community.wildernesslabs.co. This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

PeterB's Content

There have been 5 items by PeterB (Search limited from 17-May 21)


By content type

See this member's

Sort by                Order  

#28906 Netduino Firmware v4.2.0 RC5 (Netduino + Netduino Plus)

Posted by PeterB on 12 May 2012 - 02:19 PM in Beta Firmware and Drivers

On the Netduino you need to do the same you´ve done to put the new firware on it, just upload the desired version, the step are the same. On the VS2010 you just need to select the .Net Micro Framework 4.1 as your target framework (right click on the project, Properties -> Application -> Target Framework), it will as to reopen your project after you change that, and it´s all back to 4.1.

Hope it helps!

Thanks Firegun. I'm back on 4.1.06 but it looks like I've toasted DIO 0 & 1 :(
I'd just got into bed and was tablet surfing when I read your reply, got up, rugged up and now back to where I was last night (minus COM1).

Only have the 1 N+, local suppliers don't have NGO yet and out of stock of N+.

I was going to use both COM ports as I just have the Arduino monitoring the Solar Hot Water system working and I was about to engage in another Arduino to monitor the wireless Weather Station (Practical Arduino style).



#28896 Netduino Firmware v4.2.0 RC5 (Netduino + Netduino Plus)

Posted by PeterB on 12 May 2012 - 01:20 PM in Beta Firmware and Drivers

After the upgrade to 4.2rc5 I had problems with my serial reads on COM1. Data was being corrupted and exceptions were being thrown from Encoding.UTF8, which I found was due to data ASCII>126. The character stream should not have been giving characters in the upper section of the ascii table so I was confused. Looking at the data it became obvious that it was corrupted. I reset the Arduino that sends the serial data, but still corrupt data stream. I decided to swap to COM2 and all was okay again. Is DIO 0 & 1 (aka COM 1) used differently in 4.2rc5? Also what do I need to do to go back to 4.1.06 on the N+ and in 2010VC?



#28891 Netduino Firmware v4.2.0 RC5 (Netduino + Netduino Plus)

Posted by PeterB on 12 May 2012 - 11:42 AM in Beta Firmware and Drivers

If you are not already, try using the 4.2 drivers available here: http://forums.netdui...-for-net-mf-42/


I downlaoded all of the suggested (required) files listed http://forums.netdui...?showtopic=2768 I also tried the driver files you suggested, but still crash PC by pulling USB during a hung deployment.

I have also noticed that code that worked before in 4.1 now throws exceptions. Unfortunately I was not using any versioning of files so I can't go back. I have to work my way through these new issues.



#28866 Netduino Firmware v4.2.0 RC5 (Netduino + Netduino Plus)

Posted by PeterB on 12 May 2012 - 02:01 AM in Beta Firmware and Drivers

Hi Peter,

Can you provide a bit more info on what's happening when you try to upgrade? As long as you erase the board before flashing the new firmware, you should be fine.

Let's see if we can get to the bottom of this for you :)

Chris

Hi Chris,

When I did the erase I was using the ERASE in MF_DEPLOY. Reading later post in this thread I discovered I needed to do the full erase "Short 3.3v to GOLD ERASE PAD - near DIO 0". Also I found I needed to get AMTEL SAM-BA to install the boot-loader.

After reading DaveV's post, your post to Laurelle and the Wiki article http://wiki.netduino...ep-by-step.ashx I was able to finally get 4.2rc5 installed.

I had an issue were my Win7x64 machine would reboot if I pulled the USB to the Netduino+ out. This occurred even after reflashing the N+ with MF_DEPLOY. I noticed that during the install of AMTEL SAM-BA 2.11 that Win7 popped up a warning message about the driver that was going to be installed. I subsequently UN-installed AMTEL SAM-BA 2.11 and restarted the PC. The reboot PC problem is no longer present. Must be the SAM-BA driver.
EDIT: the REBOOT PC problem still exists if I pull the USB plug out during a DEPLOY hang.

I had to change the REFERENCES in my project. I used the suggested references from the template project now that I'm on 4.2.

Love the fact there is more RAM. I was running low, so now I can boost the size of my buffers for servicing HTTP request. Now I'm on 4.2 I will look at using later WebServers suggested/linked on the forums, as I'm currently using Fred's from 2010.

Thanks for your assistance.



#28826 Netduino Firmware v4.2.0 RC5 (Netduino + Netduino Plus)

Posted by PeterB on 11 May 2012 - 03:20 PM in Beta Firmware and Drivers

I have tried doing the upgrade but it failed during the Depolying ER_FLASH.hex with the error
Error: Unable to deploy to device.

I went back to 4.1.06 and that deployed okay (erase between deployment). However, after I changed teh Network and then deployed my previously working solution the program crashes. I changed the NETMF to 4.1 in VC

I have tried going back 4.2rc5 again following the exact steps including erase. I must be doing something wrong but for the life of me I can work it out, Yeah 01:17 in the morning but I'm sure I'm following the steps.

I notice that it is trying to erase again before deploying ER_FLASH. here is the info from MF_DEPLOY

Chk signature 
Signature PASS
Not Supported
Connecting to NetduinoPlus_NetduinoPlus...Connected
Not Supported
Pinging... TinyBooter
Bootloader build info: Netduino Plus by Secret Labs LLC
Not Supported
DeviceInfo is not valid!




home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.