Netduino home hardware projects downloads community

Jump to content


The Netduino forums have been replaced by new forums at community.wildernesslabs.co. This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.
Photo

Application Deployment problems

hex deployment

  • Please log in to reply
2 replies to this topic

#1 PhilG

PhilG

    Advanced Member

  • Members
  • PipPipPip
  • 42 posts
  • LocationMaine

Posted 09 November 2013 - 01:11 PM

I am having very little luck getting a hex file from MFDeploy.  I am using an NP with 4.2.0.1 firmware and XPSP3.  When I hold the button down and reconnect the USB cable (no power adapter used) MFDeploy will very occasionally return the required [font="'times new roman';"]"Pinging TinyBootloader"[/font] and then I can successfully create a hex file.  Sometimes I have to unplug/replug the NP continuously (experimenting with the length of the button push) before it catches and I can create a hex file.  I have tried it while connected directly to the PC and through a hub with no difference.

I want to spend more time debugging code and less fiddling with this silliness. Is there an alternative way to get the hex file? 



#2 Chris Walker

Chris Walker

    Secret Labs Staff

  • Moderators
  • 7767 posts
  • LocationNew York, NY

Posted 09 November 2013 - 10:36 PM

Hi PhilG, One option is to switch back to the legacy MFUSB drivers (rather than the newer WinUSB drivers)... That will enable you to grab the application HEX file on a gen1 Netduino from any state. http://forums.netdui...-mfusb-drivers/ Does that help? Chris

#3 PhilG

PhilG

    Advanced Member

  • Members
  • PipPipPip
  • 42 posts
  • LocationMaine

Posted 10 November 2013 - 02:54 PM

Chris,

Thanks for the reply.

I think I followed the directions correctly.  It tells me that the specified location does not contain information about my hardware and then cycles back to the previous screen (see attached). 

 

 

More info:  I tried uninstalling the driver first and got the same result.  I also downloaded the SDK again and ran repair but that didn't help. 

So, if I were to replace my NPs  with NP2's would this problem be fixed along with the data corruption problems I have had after writing to SD and power cycling?  I need to spend more of my time doing code development.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.