Netduino home hardware projects downloads community

Jump to content

The Netduino forums have been replaced by new forums at This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

Are my netduino 2s fried?

  • Please log in to reply
3 replies to this topic

#1 mbyamukama



  • Members
  • PipPip
  • 16 posts

Posted 05 July 2013 - 09:35 AM

I have 3 faulty netduino 2s and 1 netduino plus 2.


With the 1st netduino 2 and the netduino plus 2, when plugged into the PC's USB port, both the power LED and the blue LED go on and the blue LED STAYS on. They are not recognised in any way by the PC, even in bootloader mode (at first I thought it was a firmware problem).

The NP2 acted this way when I attempted to program it while it was in a circuit, in which it was connected to an MRF24J40 transciever (that attempted to draw about 100 mA from the 3.3V pin of the NP2). I dont know if 100mA is a lot but that was the last time it worked!

For the N2, I accidentally connected its RX pin of COM2 (instead of the TX) to a the RX of a USB-TTL adapter. This should not be an issue (as nothing was coming into the netduino) right?! . But that was the last time it worked!


The 2nd Netduino 2 hisses when plugged into the PC. I am sure this one is a goner! I dont exactly know what happened. It just started doing it. Both LEDS go on and STAY on. Then after about 1 second, the hissing starts. And It heats up. The RQB36 IC also heats up very much. (It does manage to go into bootloader mode for just about a second and then gets ejected).


The 3rd Netduino 2 powers up but the blue light doesnt come on that first time. For this one, I got a USB power issue when i plugged it in 2 months ago. I think it was trying to draw a lot of current from the PC. It doent get recognised at all. It doesnt go into bootloader mode. Doesnt heat up. Its just like a vegetable!


Any troubleshooting will help, but I think we need some form of diagnostic tool for the Netduinos! Incidentally, the Netduino 1s have never given me any issue since the beginnning. They Just work! The 2s seem to be giving me some reliability problems as some of them get issues that dont really have an explanation (from me!)

#2 Nighthawk



  • Members
  • PipPip
  • 21 posts

Posted 05 July 2013 - 10:56 AM

Quite a few times I mistakenly connected RX pin to RX of USB-TTL cable (and TX to TX)... even when there was stuff that was supposed to be sent/received over the cable (until I figured out why it was not working!). Never had an issue.

#3 ziggurat29


    Advanced Member

  • Members
  • PipPipPip
  • 244 posts

Posted 05 July 2013 - 06:44 PM

mercy!  stop blowing them up, haha.


I can tell your from personal experience that the 'hissing' sound is probably the inductor on the switching supply being overloaded trying to regulate.  This is not a good sign.  I myself broke an NP2 somehow (I like to blame it on a cruddy shield I was using, but truthfully it could have been from ESD that was purely my fault).  In that case, the processor was damaged, and sunk a lot of current, loading the regulator, and producing a detectable whine.  For a while I used the dead board for measurements for mounting brackets, but then one day I decided to use it for soldering practice, and removed the cpu and replaced it with a new one.  Now I have a resurrected NP2! (and with a nicer processor with crypto accelleration)  I don't know that I'd recommend doing that in general, but now you know you can, at least.  If the processor is the actually damaged part (though likely it is since these circuits are so simple).


Big question is probably why you are killing so many of them (3+1=4 now?).  I do second Nighthawk's experience that TX-TX is not an automatic death sentence -- I've made that booboo a couple times too and gotten away unscathed -- but then again you aren't supposed to do that, and logically you'd think it would be bad news if they were driving opposite ways, so certainly avoid it.

#4 mbyamukama



  • Members
  • PipPip
  • 16 posts

Posted 08 July 2013 - 01:01 PM

Actually its my students blowing them up! though they belong to the department technically. Any idea why the inductor would be overloaded? We have always operated these devices from USB ports

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.