Netduino home hardware projects downloads community

Jump to content

The Netduino forums have been replaced by new forums at This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

USB Device - Always enumerates as Netduino in Device manager

  • Please log in to reply
2 replies to this topic

#1 endo



  • Members
  • PipPip
  • 14 posts

Posted 23 January 2013 - 05:06 AM

Hi Support,


I have set the debugger to COM1 using mfdeploy on the Netduino Plus 2 to program in VS via COM1

I have Deployed the Sample HID keyboard code, originally wrote for the Netduino. When debugging it appears that the USB controller and USB device are starting, but Device manager always shows Netduino. 

I have deployed, and rebooted the device and still the same.


I have also tried to use a 7.5 V power supply to power the board, however I cannot program via serial unless the Netduino Plus is connected via USB to the same PC, and external power is disconnected. Im not sure why powering the board would prevent programming.


 Are USB devices currently supported? Is there any issues with programming with external power?


Thanks again for your support,


#2 Philip



  • Members
  • PipPip
  • 26 posts
  • LocationPreston, England

Posted 23 January 2013 - 07:52 PM

Hi Support,


Can you help clear my confusion.  I have a number of (old) Netduinos running 4.1 (and I'm happy with them)


Today I got a Netduino 2 (running 4.2?) and wondered about making a USB HID device (and deploying via serial).  


There seems to be lots of stuff about making the Netduino 2+ into a HID device, and lots about using experimental 4.1.1 (or whatever) with the old Netduino, but nothing? about how to turn a new Netduino2 into a HID device.


Is it any different to the old Netduino.  Are there any instructions on how to do it?  





#3 Chris Walker

Chris Walker

    Secret Labs Staff

  • Moderators
  • 7767 posts
  • LocationNew York, NY

Posted 23 January 2013 - 08:42 PM

Hi endo, Phil: The NETMF USB Client feature isn't supported yet on any 4.2 firmware (on gen1 or gen2 boards), but we're currently working on adding it to Netduino 2, Netduino Go, and Netduino Plus 2. It's a pretty sophisticated feature so it may take a while to get out of development. We actually added some extra hardware to the new gen2 boards specifically so we could support these types of scenarios via firmware enhancements. Chris

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.