Netduino home hardware projects downloads community

Jump to content

The Netduino forums have been replaced by new forums at This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

cant deploy to plus 2

  • Please log in to reply
3 replies to this topic

#1 ash


    Advanced Member

  • Members
  • PipPipPip
  • 66 posts

Posted 11 January 2013 - 11:01 AM

with have the new batch and ive upgraded to 4.2.2. also updated the netdunino sdk. ive already got the 4.2 qef sdk installed but when i try to deploy my old netdunino plus code to the plus 2 it fails!!!! please help :(

#2 ash


    Advanced Member

  • Members
  • PipPipPip
  • 66 posts

Posted 11 January 2013 - 11:56 AM

got it going but ive got an issue which im not sure about yet but i tried to go back to my plus 1 and now it wont deploy to that!!!! we have devices with version 1 out there :(

#3 Gutworks


    Advanced Member

  • Members
  • PipPipPip
  • 363 posts
  • LocationOttawa, Ontario

Posted 11 January 2013 - 03:39 PM

Hi ash, 


I have't noticed any similar issues, but generally before I run a previous project with new firmware and assembly files, I clean my project before deploying just to make sure there isn't any caching issues happening. To do so in Visual Studio, go to the Build menu and select Clean Solution before deploying the project. 


If that doesn't work I wonder if you have a small test solution that I could use to try and reproduce.



#4 Chris Walker

Chris Walker

    Secret Labs Staff

  • Moderators
  • 7767 posts
  • LocationNew York, NY

Posted 11 January 2013 - 04:19 PM

Hi ash, The device name of the original Netduino Plus is "NetduinoPlus" and the device name of the new Netduino Plus 2 is "Netduino". Be sure to change the deploy target in "Project Properties > .NET Micro Framework" when switching boards...or rename your Netduino Plus 1's USB name to "Netduino" in MFDeploy. Also, for cross-board compatibility, be sure to use SecretLabs.NETMF.Hardware.NetduinoPlus.dll v4.2.2. This is included in the Netduino Plus 2 4.2.2 firmware thread...and will also be installed by default with next week's Netduino SDK update. If you're running into troubles deploying to a Netduino, we're here to help. We just need a bit of info and a little patience; we're here to help community members be successful in both their personal projects and commercial endeavors. Chris

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.