Netduino home hardware projects downloads community

Jump to content

The Netduino forums have been replaced by new forums at This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

VS hanging at "Preparing to deploy assemblies to the device"

  • Please log in to reply
3 replies to this topic

#1 Krokonoster



  • Members
  • PipPip
  • 11 posts

Posted 06 November 2012 - 09:07 PM

Hi, First of all I'm completely new to Netduino, so please bear with me. (Seasoned C# programmer though, so might be able to make some contributions later :-)) I just got my Netduino Plus an wrote my first "Blinky" app. When I run the application it seems to hang at "Preparing to deploy assemblies to the device" After the longest time, I get an error "Unable to communicate with device - USB:NetduinoPlus" However, immediately after that last error, the board's led start blinking as I coded it. Wasn't sure if it's something else, so changed the interval of the led to go on and off, and it's definitely the program I've been running. I read something about updating your firmware, but figured I'd first ask and make sure. For what it matter, I'm using VS 2010 Ultimate (the .net Microframework templates seems not to be available in VS11?) Cheers, Krok

#2 caEstrada


    Advanced Member

  • Members
  • PipPipPip
  • 84 posts

Posted 06 November 2012 - 09:15 PM

Krokonoster, Welcome. If you are using NetMF 4.2, the very first time you download a new program to NetduinoPlus, VS2010 closes without any message. There is an explanation but I do not remember why. However, after that, everything works fine. Regards, Carlos A. Estrada

#3 Baqs


    New Member

  • Members
  • Pip
  • 5 posts

Posted 09 November 2012 - 03:27 AM

This is normal with NETMF devices, probably a problem with VS. I have had the same issue (frequently) with different boards (Netduino Plus, FEZ Spider and FEZ Panda II) all with the latest firmware. In case you fail to deploy after several attempts (happened once to me) simply unplug the device, close and reopen VS, and plug the device again, that fixed it. Update: In case VS still fails to communicate with your Netduino after a few attempts you might want to check this post: http://forums.netdui...p__216#entry216

#4 Nicky


    Advanced Member

  • Members
  • PipPipPip
  • 78 posts
  • LocationDenmark

Posted 09 November 2012 - 05:24 PM

When unplugging, remember to cancel the deployment. If not, you risk getting BSOD.

TCP Listener (Beta) · FTP Server (Alpha)
Netduino Plus Go Module · Xml Parser

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.