Netduino home hardware projects downloads community

Jump to content

The Netduino forums have been replaced by new forums at This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

Getting Started Pain

  • Please log in to reply
No replies to this topic

#1 millerabode


    New Member

  • Members
  • Pip
  • 1 posts

Posted 20 August 2016 - 09:20 AM

I've recently started developing a project using a Netduino 3 Wifi having not really used Netduino boards before. I have finally been able to write code in VS Express 2013 and executed it on the board but it took quite some time to get to this point as I originally tried to use the latest versions of everything and ran into problems - hence the following queries that people here may be able to answer:


I have updated the netduino firmware using the latest available on the site


The latest .net microframework is 4.4 - is this not supported by the latest firmware as changing the project to use this framework I get the following when deploying to the board:



Attaching deployed file.


Assembly: Microsoft.SPOT.Hardware.SerialPort (




*                                                                     *


* ERROR!!!!  Firmware version does not match managed code version!!!! *


*                                                                     *


*                                                                     *


* Invalid native checksum: Microsoft.SPOT.Hardware.SerialPort 0x4E6685A9!=0x1C1E5B6D *


*                                                                     *






Link failure: some assembly references cannot be resolved!!



Assembly: Object ( needs assembly 'get_Directory' (


Assembly: Object ( needs assembly 'Microsoft.SPOT.Net' (


Assembly: Object ( needs assembly 'Microsoft.SPOT.Native' (


Error: a3000000


Waiting for debug commands...


The program '[1] Micro Framework application: Managed' has exited with code 0 (0x0).



The other main issue was that I started trying to use Visual Studio 2015 Community Edition. I managed to get the Netduino templates available such that I could create a Netduino application but on trying to build the solution I get:

could not find library 'Microsoft.VisualBasic.dll'
How do I fix that?
Thanks in advance



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.