Netduino home hardware projects downloads community

Jump to content


Photo

Netduino 3 Ethernet Static IP Issues


  • Please log in to reply
4 replies to this topic

#1 martinarcher

martinarcher

    Member

  • Members
  • PipPip
  • 16 posts

Posted 01 May 2016 - 11:39 PM

Has anyone found a solution to setting static IP's with the N3Enet?  I've now transitioned to Netduino 3's (I should say am trying to transition) but am struggling with this.  My Netduino 2 Plus I could set a static IP using .NET MF4.2 and the following line of code...

 

Microsoft.SPOT.Net.NetworkInformation.NetworkInterface.GetAllNetworkInterfaces()[0].EnableStaticIP(ipAddress,subnetMask,gateway);

 

Now with my new N3Enet and .NET MF4.3 I get....

 

A first chance exception of type 'System.ArgumentException' occurred in mscorlib.dll
A first chance exception of type 'System.ArgumentOutOfRangeException' occurred in mscorlib.dll
An unhandled exception of type 'System.ArgumentOutOfRangeException' occurred in mscorlib.dll
 
Any help would be really appreciated.  I need to get this working quickly (or find more Netduino Plus 2's!)


#2 martinarcher

martinarcher

    Member

  • Members
  • PipPip
  • 16 posts

Posted 04 July 2016 - 09:43 PM

Any news or progress on this?  I bought some more Netduino Pus 2's to hold me over for a bit but if this isn't sorted out I'll need to bail form the Netduino platform and look for a new controller to build my product with.  Chris?  Any news??



#3 Nevyn

Nevyn

    Advanced Member

  • Members
  • PipPipPip
  • 1070 posts
  • LocationNorth Yorkshire, UK

Posted 05 July 2016 - 06:31 PM

Any news or progress on this?  I bought some more Netduino Pus 2's to hold me over for a bit but if this isn't sorted out I'll need to bail form the Netduino platform and look for a new controller to build my product with.  Chris?  Any news??

 

Chris has been absent from the forums since November 2015.

 

Regards,

Mark


To be or not to be = 0xFF

 

Blogging about Netduino, .NET, STM8S and STM32 and generally waffling on about life

Follow @nevynuk on Twitter


#4 TechnoGuy

TechnoGuy

    Advanced Member

  • Members
  • PipPipPip
  • 51 posts
  • LocationCanada

Posted 06 July 2016 - 01:45 AM

Please see these issues I logged against the Netduino.IP repository on Github back in November 2015.

 

https://github.com/n...duino.IP/issues

 

  • Problems with EnableStaticDns() & EnableDynamicDns() methods in NetworkInterface class
  • EnableDhcp() not implemented in NetworkInterface class
  • EnableStaticIP() not implemented in NetworkInterface class

With Netduino 3 there was a move towards the implementation of lwIP (i.e. "Lightweight Internet Protocol").  I believe this was done in anticipation of what would be coming out in NETMF 4.4.  Anyway, the above methods DO work on Netduino Plus 2 and DON'T work on Netduino 3.  I'm not sure if they're things that should have been implemented by the board developer or if they're part of NETMF 4.4.

 

Anyway, if they're things that are important to you, please visit the issue list on Github and add your comments / reaction (vote up) the issues.

 

See also this topic thread on the Netduino Forums:

http://forums.netdui...it-doesnt-work/


- Ian

 

My Current Dev Boards:

  • 3 x Netduino Plus 2
  • 1 x Netduino 3 WiFi

#5 martinarcher

martinarcher

    Member

  • Members
  • PipPip
  • 16 posts

Posted 18 December 2016 - 02:18 AM

Thanks for the reply.  Bummer to hear Chris is MIA.  I'm blown away that Static IP's would have been left out in a micro controller firmware design.  I'm hoping it gets taken care of.  I'll add some comments on Github.

 

Thanks!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.