Netduino home hardware projects downloads community

Jump to content


Photo

can't run on target debugger - nd3 wifi

target reboot cant attach to process debugger error

  • Please log in to reply
No replies to this topic

#1 mjd

mjd

    New Member

  • Members
  • Pip
  • 7 posts

Posted 15 April 2016 - 12:59 AM

Hi all

 

I've encountered an error that means i can't run on-target debugging. After (successfully) deploying my program to the nd3 wifi the device reboots 11 times then the debugger terminates, the nd3 then runs the program successfully. As a work around i tried 'attach to process' in Visual Studio but although it displays debug messages in the output window breakpoints in active threads never get 'hit' (appear disabled).

 

i have installed all the newest .NET Micro Framework SDK v4.3, sdk Netduino SDK v4.3.2.1 and board firmware v4.3.2.3 and using Visual Studio 2013 on windows 10.

 

i have tried different usb ports, even cables etc but cant find a solution. Some other posts described 'cyclic rebooting' and similar issues e.g. by kerk-akkerFeb 24 2016 10:49 PM but those suggestions wont resolve this.

 

Watching the board leds i see that after the deployment of assemblies completes the board doesn't seem able to initialise the network (at lease im guessing that is a possible scenario). The network led lights orange for a few seconds and goes off, then the blue led illuminates for a few seconds then that cycle repeats 6 times before the debugger exits. Then the board loads the program and network immediately becomes active (network led shows green).

 

i have tried both setting dynamic and static IP, but it has no effect on the outcome. i am using the 'wait for network availability' code presented at http://forums.netdui...ork-connection/ The test program is a bare bones program - just runs the wait for network then prints 'thread alive' message and sends a network message to a REST endpoint in a loop with a sleep.as mentioned the program works as expected but cant run the debugger.

 

Any comments appreciated.

 

Is there any way to identify the 'unspecified device errors' (as shown in the output - below). Are there any time-outs of other parameters to experiment with with debugger / target boot loader, or log view?

 

mike

 

 

below is the output up to the first target reboot

 

....... [deployment description text (no errors)]

Assemblies successfully deployed to device.
Restarting interpreter...
Attaching to device...
Waiting for device to initialize...
The debugging target and the debugger engine failed to initialize because of unspecified device errors.
The debugger engine thread has terminated unexpectedly with error 'Could not reconnect to the debugging target after rebooting it.'.
 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.