Netduino home hardware projects downloads community

Jump to content


Photo

Netduino Application (Universal) Template: Shows up in VS2013 Express but not in VS2013 Community

Netduion Application template vs2013 express community

Best Answer TechnoGuy, 26 August 2015 - 01:31 AM

Hi.  This appears to have been a "goof up" on my part.  I think it stemmed from a glitch that occurred on my computer when I installed Visual Studio 2013 Community and wound up reinstalling it in place (as opposed to an uninstall/reinstall).

 

Anyway, I wound up doing a serious cleanup - purging several old versions of Visual Studio and in fact ditching Visual Studio 2013 and moving to Visual Studio 2015.

 

I'd just like to report that all is well now.

 

Chris - with regard to your response, I'd like to acknowledge that a "Repair" option IS available for the Netduino SDK.  However it appears (for me) only after I choose Uninstall from Programs & Features.  I was confused by this initially, as I find that many other programs expose "Change", "Repair" & "Uninstall" right from the programs list.

 

Finally, I see no reason for this topic to remain on the Netduino forums.  Maybe it could be purged?  Don't want to "clutter up" the Internet...

Go to the full post


  • Please log in to reply
4 replies to this topic

#1 TechnoGuy

TechnoGuy

    Advanced Member

  • Members
  • PipPipPip
  • 51 posts
  • LocationCanada

Posted 08 August 2015 - 04:49 AM

Hi All,
This is probably a goof up on my part. Wondering if others are seeing it also...
I have BOTH of these Visual Studio versions installed on my Windows 7 PC:
  • Visual Studio Community 2013 
  • Visual Studio Express 2013 for Windows Desktop
In addition to the Microsoft development environments, I have the following .NET Micro Framework packages installed as well (installed as per the instructions found on the Netduino downloads page.
  • .NET Micro Framework SDK 4.3 
  • .NET Micro Framework Plugin for VS2013 
  • Netduino SDK 4.3.2.1 [shows up as Netduino SDK 4.3.2 (May 2015)]

I am seeing differences between Visual Studio Express & Visual Studio Community when I go to create a New Project using the Micro Framework templates.

In Visual Studio Express 2013, I see 5 different templates:

  • Class Library
  • Console Application
  • Device Emulator
  • Netduino Application (Universal)    <= This one is missing in Visual Studio Community
  • Window Application

However, in Visual Studio Community 2013, I only see 4 templates:

  • Class Library
  • Console Application
  • Device Emulator
  • Window Application

The Netduino Application (Universal) template is missing from the list.  Please see attached screen captures.

Can anybody tell me what I goofed up here?

Thanks in advance...

Attached Files


- Ian

 

My Current Dev Boards:

  • 3 x Netduino Plus 2
  • 1 x Netduino 3 WiFi

#2 Chris Walker

Chris Walker

    Secret Labs Staff

  • Moderators
  • 7767 posts
  • LocationNew York, NY

Posted 08 August 2015 - 07:36 AM

Hi TechnoGuy,

What happens if you run a repair (through Control Panel > Programs and Features) on the Netduino SDK?

Chris

#3 TechnoGuy

TechnoGuy

    Advanced Member

  • Members
  • PipPipPip
  • 51 posts
  • LocationCanada

Posted 08 August 2015 - 08:07 AM

Hi Chris,

 

I only see an "Uninstall" option for the Netduino SDK in Programs & Features (Control Panel).  There's no "Repair" showing (for me).

 

I see "Netduino SDK v4.3.2 (May 2015)" in Programs & Features, by the way...

 

In contrast, I DO see Repair as an option for the Microsoft .NET Micro Framework SDKs that I have installed.  Change & Uninstall show up also...

 

I checked this on a Windows 7 machine and on one running Windows 10.

 

- Ian


- Ian

 

My Current Dev Boards:

  • 3 x Netduino Plus 2
  • 1 x Netduino 3 WiFi

#4 TechnoGuy

TechnoGuy

    Advanced Member

  • Members
  • PipPipPip
  • 51 posts
  • LocationCanada

Posted 26 August 2015 - 01:31 AM   Best Answer

Hi.  This appears to have been a "goof up" on my part.  I think it stemmed from a glitch that occurred on my computer when I installed Visual Studio 2013 Community and wound up reinstalling it in place (as opposed to an uninstall/reinstall).

 

Anyway, I wound up doing a serious cleanup - purging several old versions of Visual Studio and in fact ditching Visual Studio 2013 and moving to Visual Studio 2015.

 

I'd just like to report that all is well now.

 

Chris - with regard to your response, I'd like to acknowledge that a "Repair" option IS available for the Netduino SDK.  However it appears (for me) only after I choose Uninstall from Programs & Features.  I was confused by this initially, as I find that many other programs expose "Change", "Repair" & "Uninstall" right from the programs list.

 

Finally, I see no reason for this topic to remain on the Netduino forums.  Maybe it could be purged?  Don't want to "clutter up" the Internet...


- Ian

 

My Current Dev Boards:

  • 3 x Netduino Plus 2
  • 1 x Netduino 3 WiFi

#5 nlsa

nlsa

    Member

  • Members
  • PipPip
  • 11 posts

Posted 29 October 2015 - 09:28 PM

I'd like to confirm that Ian's problem was not unique.  I experienced the same scenario, Micro Framework appears in VS Express 2013 but not in Community 2013.  As a consequence, Community 2013 can't load Netduino solutions.  Like Ian, I eventually gave up and moved to Community 2015.

MRO







Also tagged with one or more of these keywords: Netduion Application template, vs2013, express, community

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.