Netduino home hardware projects downloads community

Jump to content

The Netduino forums have been replaced by new forums at This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

Netduino Plus 2 Firmware Upgrade in Windows 7 64 bit edition

NNetduino Plus 2 Firmware v4

  • Please log in to reply
2 replies to this topic

#1 smdunio


    New Member

  • Members
  • Pip
  • 2 posts

Posted 17 February 2015 - 11:28 AM

Hi Everyone,

                   I was trying to upgrade my Netduino Plus 2 Firmware to v4.3.1.  I erased the Netduino using the gold pad and 3.3V. After reboot of Netduino, the drivers would not install on Windows 7 x64. In the device manager its showing unknown device. I have installed the following

  1. Microsoft .net Micro Framework SDK 4.2 (QFE2)
  2. Netduino SDK v4.3.1 (Nov 2014)
  3. DfuSe Demo V3.0.2 Setup amd64 (STMicroelectronics)
  4. sam-ba_2.15
  5. Microsoft VIsual C# 2010 Express

When I am connecting the device in the Bootloader mode windows is unable to recognize. In MFDeploy when I am selecting the USB  Netduino Plus 2 is not flashing up automatically. I tried it  many ways. 

Link 1

Link 2

Link 3


If anyone can help it would be good for me. Is my Netduino is dead how can I check that.


Thanks in Advanced.


#2 Wernfried


    Advanced Member

  • Members
  • PipPipPip
  • 33 posts

Posted 18 February 2015 - 08:44 AM

I had a similar problem, not with W7 but with W8.1. Unfortunately I posted my question in the wrong topic.




I figured out, that the USB driver was not installed together with SDK 4.3 for some reason. Chris told me, the drivers should be installed, but they weren't. I had success with manualy installing the drivers from a 4.2 installation.


Here is the whole process I'd run into this problem.

First the 4.2 was installed, all worked well

After switching to Visual Studio 2013 I installed the 4.3 beta and it worked also well

The I read, Mcrosoft released the 4.3 RTM and I installed it. With this installation it seemed the previuos Netduino 4.3 SDK was gone, I couldn't compile my projects anymore, missing assemblies.

Then I reinstalled the Netduino SDK but the driver for USB was missing. Plugging in the N+2, Windows tried to install the USB driver, but ended up with an error.


Chris mentioned, that the USB driver shall be in the folder "C:\Program Files\Secret Labs\Netduino SDK\Drivers" for 64bit-Systems. But there wasn't. I have had a second installation on another laptop (not the 4.3 RTM) and so I could copy the USB driver. Now installing the USB driver manually and all worked as a glance.


May be there is a missing step during installation of the Netduino SDK when there exists an other version. Publishing the USB driver here in the forum separately from the SDK could help others I think.

#3 Chris Walker

Chris Walker

    Secret Labs Staff

  • Moderators
  • 7767 posts
  • LocationNew York, NY

Posted 18 February 2015 - 08:39 PM

Hi smdunio,

On the newer gen2 gear, the gold pad is just a shiny alignment marker for the assembly robots. Erasing boards before reflashing was only required on the original gen1 gear.

To reflash your Netduino Plus 2 (gen2) board, you'll use Netduino Update. The ST flashing drivers should, in theory, download automatically via Windows Update. If not...grab a copy of the ST DFU tools (as linked in the forum post alongside the firmware).

Does that help get you up and running?


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.