Netduino home hardware projects downloads community

Jump to content

The Netduino forums have been replaced by new forums at This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

MetaDataProcessorDat fails: MPP: error MP0000: CLR_E_FAIL

compilation firmware

  • Please log in to reply
1 reply to this topic

#1 timothyp



  • Members
  • PipPip
  • 24 posts

Posted 10 February 2015 - 08:12 AM



I tried compiling 4.3 with Yagarto before following the instructions on this page:


However that results in 116 errors looking exactly like this:



The command " "\-gcc.exe .................................. exited with code 9009.


I checked the version of yagarto, even tried different versions... didn't work.


After that I tried using the KEIL MDK toolchain.

Using that one I was able to compile the unmodified 4.3 sources.
(There was one error about a scatter file but it did not seem to affect the build of the firmware).


The problem


A reply to my previous question (http://forums.netdui...e-code-interop/)
guided me to this tutorial on how to use native interop with the .NET MF:




So I went ahead, created a new .NET MF library, generated the native code files,
put everything into place and tried to recompile the firmware again, this time including
the new native code.


The compile process started as usual and seemed to continue all the way to the end
at which point it outputs something like this:

Skipping target "ArmCompileC" because it has no outputs.


C:\PK\BuildOutput\public\Release\server\dll\MetaDataProcessor.exe -create_database C:\Users\Timothy\AppData\Local\Temp\tmpD8B3.tmp C:\PK\BuildOutput\THUMB2\MDK4.54\le\FLASH\release\NetduinoPlus2\bin\tinyclr.dat

MMP : error MMP0000: CLR_E_FAIL [C:\PK\Solutions\NetduinoPlus2\TinyCLR\TinyCLR.proj]

Done Building Project "C:\PK\Solutions\NetduinoPlus2\TinyCLR\TinyCLR.proj"
 (Build target(s)) -- FAILED.

Done Building Project "C:\PK\Solutions\NetduinoPlus2\dotnetmf.proj"
 (rebuild target(s)) -- FAILED.


"C:\PK\Solutions\NetduinoPlus2\dotnetmf.proj" (rebuild target) (1) ->
"C:\PK\Solutions\NetduinoPlus2\TinyBooter\TinyBooter.proj" (Build target) (2) ->

The generated C++ looks like this:

void NativeHelper::Hello( CLR_RT_TypedArray_UINT8 param0, CLR_RT_TypedArray_UINT8 param1, HRESULT &hr )

After creating the managed project for the interop library and generating the stubs,
I did not make any changes to those files. I wanted to make sure it compiled as is first,
that's why the method above has an empty body.


Any ideas on what might be going on?

Is the error caused by the Keil MDK toolchain or has the compilation process already completed
at the time of the error and is there something else going on?

#2 timothyp



  • Members
  • PipPip
  • 24 posts

Posted 06 March 2015 - 04:04 AM

I finally figured out what the problem was, and it's quite a blunder on my part  :)


All the paths where referring to the "release" folder, while I was compiling the debug build.

Also tagged with one or more of these keywords: compilation firmware

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.