Netduino home hardware projects downloads community

Jump to content

The Netduino forums have been replaced by new forums at This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

Bricked Mini

  • Please log in to reply
4 replies to this topic

#1 netnut


    New Member

  • Members
  • Pip
  • 3 posts

Posted 31 July 2014 - 04:15 AM


I have a mini that I somehow bricked. I have tried every possible combination of SAM-BA, RS-232, TTL, gold pad reset that I can find, but it still refuses to respond to anything I throw at it.


It has 5V out on p21 when 12V is applied to p24 and there is just a slight amount of heat generated from the core.


Each of my serial adapters worked fine on the mini prior to it failing, so I know it is not my comm hardware.

I have tried powering with 9V battery, 8-AA's and power from the TTL adapter.


Is there a sure-fire method of resurrecting a device?

Is there somewhere I can send it for a post-mortem? (it's no good to me now...)



Bryan Schremp


#2 Chris Walker

Chris Walker

    Secret Labs Staff

  • Moderators
  • 7767 posts
  • LocationNew York, NY

Posted 31 July 2014 - 05:05 AM

Hi Bryan,

Sorry for the troubles. No fun :( Let's see if we can help really quickly.

I know that you've tried quite a few combos, but just to make sure:
1. Please disconnect any components from your Netduino Mini.
2. Power the Netduino Mini via pin 24 (with GND at pin 23)
3. Apply 5V power to the ERASE pad by shorting it to pin 21.
4. Connect RX/TX/GND from your RS-232 serial adapter (not TTL serial) to pins 1/2/4.

5. Reboot your computer. SAM-BA needs a good OS reboot sometimes.
6. Run SAM-BA, select your serial port and AT91SAM7X512-EK from the drop-down.
7. Connect

Are you still unable to re-flash the bootloader onto your Netduino Mini?


#3 netnut


    New Member

  • Members
  • Pip
  • 3 posts

Posted 31 July 2014 - 07:45 PM

Thanks for the assist Chris.


I get 2 responses from SAM-BA when performing those steps: "No valid processor ID found" or "Communication Error". I am not sure what triggers the different response.


I also tried MFDeploy, with no success.

#4 netnut


    New Member

  • Members
  • Pip
  • 3 posts

Posted 27 August 2014 - 08:08 PM


I just heard that you will be in my "neighborhood" tomorrow eve. I'll bring the board into the SLAB meeting for you to take a peek.



Bryan Schremp

#5 Dr Who

Dr Who

    Advanced Member

  • Members
  • PipPipPip
  • 261 posts
  • LocationNYC

Posted 02 September 2014 - 05:18 PM

And were you successful? Did you get your device to work? And did you enjoy your visit?

Doctor Who
"This signature does not exist!"

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.