Netduino home hardware projects downloads community

Jump to content


The Netduino forums have been replaced by new forums at community.wildernesslabs.co. This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.
Photo

Unable to deploy firmware to mini


  • Please log in to reply
5 replies to this topic

#1 andrew6071

andrew6071

    Member

  • Members
  • PipPip
  • 18 posts
  • LocationUK

Posted 29 May 2014 - 07:16 PM

Hi,
 
Hopefully someone will be able to help, I've tried everything to try and deploy the 4.2 update 1 firmware to my mini, but for some reason MFdeploy is unable to see my mini
 
I've reset the mini by apply 5v to the gold square
 
deployed the bootloader (tried both ttl and rs232)
 
I can see the bootloader is on the device because when I connect to the device via the relevant port I get the following

TinyBooter v4.2.0.0
NetduinoMini Build Date: Sep 19 2012 19:39:48
ARM Compiler version 410894
MSdbgV1 ׶-@

 

when I try and connect to the device with the mfdeploy it just comes up noconnection??

 

and I've tried both ttl and rs232

 

Please help :)

 

Andrew



#2 andrew6071

andrew6071

    Member

  • Members
  • PipPip
  • 18 posts
  • LocationUK

Posted 29 May 2014 - 10:58 PM

This is really strange, just rebooted my pc, and the first time I ping the device I get the tinybooter response back, any further pings it comes up no connection

 

one thing I forgot to mention is i'm trying to use mfdeploy from 4.3

 

going to try downgrading, but it would be nice to have the 4.3 support as I've got VS 2013

 

Andrew



#3 andrew6071

andrew6071

    Member

  • Members
  • PipPip
  • 18 posts
  • LocationUK

Posted 29 May 2014 - 10:59 PM

ok, I cant install 4.2 as I only have VS 2012 and VS2013 installed ???



#4 andrew6071

andrew6071

    Member

  • Members
  • PipPip
  • 18 posts
  • LocationUK

Posted 29 May 2014 - 11:11 PM

I've just installed the 4.3 msi from codeplex (just to see), and still have the same problem

if I disconnect the serial port (its usb) and the power from the device

restart mfdeploy and ping I get ??

Pinging... TinyBooter
Pinging... NoConnection
Pinging... NoConnection

#5 Chris Walker

Chris Walker

    Secret Labs Staff

  • Moderators
  • 7767 posts
  • LocationNew York, NY

Posted 31 May 2014 - 01:06 AM

Hi Andrew,

You can grab an earlier custom version of MFDeploy from here, and then unzip it to a separate folder on your desktop:
http://forums.netdui...b-and-com1com2/

Are you able to connect to and ping TinyBooter consistently with the older MFDeploy release?

Chris

#6 andrew6071

andrew6071

    Member

  • Members
  • PipPip
  • 18 posts
  • LocationUK

Posted 31 May 2014 - 02:19 PM

Hi Chris,

Spot on worked straight away, and now the firmware is on there the mfdeploy 4.3 can see it

The thing that is different with the older version I just ping, but with the 4.3 version you have to connect first

Thanks again for your help Chris, I was pulling my hair out :)

Andrew






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.