Netduino home hardware projects downloads community

Jump to content


The Netduino forums have been replaced by new forums at community.wildernesslabs.co. This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

yameera's Content

There have been 2 items by yameera (Search limited from 21-September 18)


By content type

See this member's

Sort by                Order  

#43997 Netduino Plus 2 I2C not working for C3088 camera module

Posted by yameera on 23 January 2013 - 05:28 AM in Netduino Plus 2 (and Netduino Plus 1)

Hi Steve,

 

Thanks for your reply.

The C3088 camera module (with OV6620 image sensor) actually uses 5V for analog and 5/3.3V for digital. I am able to read other signals (such as HREF and VSYNC) from the module. Also, the module I have is an I2C module (the SCCB version of the sensor is probably old).

 

I used pull-up resistors for SDA, SCL (tried 10K and 4.7K; didn't work with either).

 

By the way, this module works fine for I2C with Arduino (device address = 0x60, speed = 100KHz).

 

I am going to try the software I2C tomorrow.

 

Meera




#43908 Netduino Plus 2 I2C not working for C3088 camera module

Posted by yameera on 22 January 2013 - 06:29 AM in Netduino Plus 2 (and Netduino Plus 1)

Hi,

Recently got a Netduino Plus 2 and hooked it up to a C3088 camera module.

I2C code for setting up the camera is not working.

Execute always returns 0 bytes transferred.

 

After reading some of the I2C posts, I upgraded the firmware to 4.2.2. But that didn't help.

Here is the code:

 

[font="'courier new', courier, monospace;"]   private I2CDevice camI2C = new I2CDevice(new I2CDevice.Configuration(0x60, 100));
  private int I2C_TIMEOUT = 1000;[/font]

[font="'courier new', courier, monospace;"]   public void writeRegister(byte register, byte value)
  {
  int result = camI2C.Execute
  (new I2CDevice.I2CTransaction[]
  {
  I2CDevice.CreateWriteTransaction(new byte[] {register, value})
  },
I2C_TIMEOUT);
  Debug.Print("writeRegister: " + register + " = " + value + " --> " + result);
  }[/font]

 

I tried the CreateWriteTransaction variation that uses internalAddress.

But that breaks with a Null Value for fieldInfo.

 

Any help is appreciated. Thanks.





home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.