Netduino home hardware projects downloads community

Jump to content


The Netduino forums have been replaced by new forums at community.wildernesslabs.co. This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

p47l4f0n's Content

There have been 3 items by p47l4f0n (Search limited from 13-November 18)


By content type

See this member's

Sort by                Order  

#34663 .NETMF V4.2 OneWire Class fails to work

Posted by p47l4f0n on 04 September 2012 - 10:46 PM in Netduino Plus 2 (and Netduino Plus 1)

Hi AlfaRomeo,

OneWire is a new feature of .NET Micro Framework 4.2, but it's a bit too big to fit in the current flash sectors.

We're currently evaluating a "special build" which would reduce the available code space a little bit, but which would add in the OneWire feature.

Chris


I look forward for the onewire implementation too. It was a horrible surprise the NotSupportedException beeing thrown :).

One remark: We use NotSupportedException to let the programmer know, that this functionality never ever will be implemented, or it does not give any logical sense to implement it. In cases, where it is already not finished, but it should be, we use NotImplementedException instead.

One question: Why didn't you suppose, the .net.mf will be extended in the future, so the additional code space will be needed? Isn't it a problem already in version 4.2 with insufficient code space? What are the options to solve the space problems?

Best regards.



#30158 Serial port deployment

Posted by p47l4f0n on 04 June 2012 - 07:44 AM in Netduino 2 (and Netduino 1)

See http://forums.netdui...b-and-com1com2/

Hi, I switched the netduino's deployment earlier following that steps.

After I wrote the first post, there in MFDeploy something happend. When the button was pressed, some binary data had been printed into MFDeploy's console. After maybe 30 seconds, when the LED turned off after the reboot is done, another binary data had been printed. Retesting this in hyperterminal is similar, but there is printed just one or two characters at the begin of reset and sometimes at the end of reset and sometimes nothing is printed. So it looks, like the netduino's COM and USB2Serial are sometimes working, but deploying an application with VS2010 is still not possible.

Attached Thumbnails

  • reset_started.PNG
  • reset_finished.PNG



#30147 Serial port deployment

Posted by p47l4f0n on 03 June 2012 - 10:17 PM in Netduino 2 (and Netduino 1)

Hello,

after many experiments I am still not able to deploy application over serial port to the Netduino.
There in MFDeploy it is possible to choose Serial/COM3, but after click to the Ping button the reponse is: "Pinging... Error: No response from device" or "Pinging... NoConnection". I know, that the whole setup (virtual machine and usb converter) could be a complication, but why.
I attached pictures, how it is connected to the PC. Did I connect it properly?
What else should I check and investigate?
Is there something other, that has to be done before the deployment/debug over serial port can be done?

One more note: Since 4.2 firmware with this setup I describe next it is not possible to debug over USB and system crashes when cabel is disconnected, so I had to switch back to the 4.1 fw.

Device: Netduino rev. B
Firmware: NetduinoFirmware_v4.1.1.0_Beta1 and Netduino_v4.1.1_beta1_CW.NETMF.OneWire-1.0.5.0
USB to serial port converter: PremiumCord USB To RS232 Cable
Netduino switched to serial deployment following this steps: http://forums.netdui...b-and-com1com2/
COM port tested: http://www.ni.com/wh...er/3450/en#toc3 and http://www.ni.com/su...al/verhyper.htm
Netduino's COM1 connection: Netduino's pin D1(TX) to RS232's pin 3(RX), Netduino's pin D0(RX) to RS232's pin 2(TX).

Other setup:
VirtualBox: 4.1.16 r78094
Host OS: Debian Squeeze (without any driver to the USB2Serial installed - but the test in guest passed).
Guest OSes tested: Windows XP 32bit SP3 or Windows 7 Enterprise 32bit

Thanks for any help.

Attached Thumbnails

  • Obraz0056.jpg
  • Obraz0057.jpg
  • Obraz0058.jpg




home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.