Netduino home hardware projects downloads community

Jump to content


The Netduino forums have been replaced by new forums at community.wildernesslabs.co. This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

V64's Content

There have been 8 items by V64 (Search limited from 16-October 20)


By content type

See this member's

Sort by                Order  

#57570 Windows 8.1 or Windows 8.1 Pro

Posted by V64 on 14 April 2014 - 07:35 PM in Netduino 2 (and Netduino 1)

Chris,

 

I have figured out to run Netduino with 4.2 sdk, 4.2 firmware etc on my Mac in W8.1 pro under Parallels

 

I am therefore reluctant to revert to a 4.1 set up, since I need to work on my app which appears to demand a 4.2 context, also your previous messages suggested thatI need to be in 4.2 context in order to load the drivers in W8.1 (which does not explicitly support Netduino drivers).

 

Whilst I may need to come back to this issue - I need to moveon and find alternative systems to use to teach my grandsons programming and electronics.

 

I therefore mark this as closed.

 

Thank-you for your time.

 

David




#57519 Windows 8.1 or Windows 8.1 Pro

Posted by V64 on 13 April 2014 - 09:02 AM in Netduino 2 (and Netduino 1)

Chris,

 

I am afraid I do not see how your last post (yesterday 08:48) relates to the points made in my last post (yesterday 07:57) - I think they 'crossed in the post'!

 

David




#57506 Windows 8.1 or Windows 8.1 Pro

Posted by V64 on 12 April 2014 - 07:57 PM in Netduino 2 (and Netduino 1)

Chris,

 

I do not really know what I am doing - but I am persistent ...

 

Laptop.

 

I (re) installed micro framework V4.1 and this allowed C# to load and build my app.

 

I downloaded the Netduino Firmware 4.2 and after many attempts finally managed to install EF_Flash and EF_config.

 

Device manager can now see the Netduino as a USB device  with driver 6.1.7601.17514.

 

VS2010 however cannot deploy my app - "an error has occurred please check your hardware".

 

Progress but the need for MicroFrameWork to be installed is a bit worrying! And it still does not run my app.

 

-------------------------

 

On my OSX (w8.1pro) the first time I tried to deploy and debug my app on the newly set up Netduino it all worked as expected!!!! My app ran just fine.

 

BUT when I stopped the debug and rebuilt/redeployed my app it ran into the " ... not initialised state; rebooting". (disconnected the Netduino and tried again - no change) shutdown parallels etc and reloaded everything - no change. So it ran once and that was it!

 

 

Thank-you for your patience and support

 

David




#57504 Windows 8.1 or Windows 8.1 Pro

Posted by V64 on 12 April 2014 - 06:27 PM in Netduino 2 (and Netduino 1)

Chris,

 

It says

 

Netduino TM

 

and in the bottom right corner it says www.netduino.com rev B 

 

David




#57501 Windows 8.1 or Windows 8.1 Pro

Posted by V64 on 12 April 2014 - 05:04 PM in Netduino 2 (and Netduino 1)

Chris,

 

Thank-you for your help - I have been responding to your suggestions in the context of my first  problem that my laptop running w8.1 does not see the Netduino - and cannot find/install drivers - and Microsoft's device manager cannot find drivers.

 

In this context I do not see why the firmware version or the SDK are relevant - microsoft tools cannot talk to the (version1?) Netduino - or am I missing something?

 

Anyway (ON MY LAPTOP)  i uninstalled MIcroFramework sdk 4.1 and checked that I have  Netmf sdk 4.2 installed, and Netduino SDK v4..2.2 - I now get the response 'Project Type not supported by this installation', and I cannot now load the Solution!

 

How do tell which Netduino board I have, and what firmware is installed? I thin k I need some help to get back a known state!

 

I have to say I more confused than when I started! The board's mfdeploy 'ping' response (in OSX/parallels/w8.1 Pro) has changed from TinyClr to TinyBooter - so I can no longer checkout the problem of being unable to run the board in OSX/... (my first problem).

 

David




#57486 Windows 8.1 or Windows 8.1 Pro

Posted by V64 on 11 April 2014 - 06:49 PM in Netduino 2 (and Netduino 1)

OK here is:

 

Attached is a screenshot of the Device Manager

 

the Control Panel>program>features shows: Netduino sdk V4.1.0 (November 2010 refresh)

 

Thank-you

Attached Thumbnails

  • Screenshot (1).png



#57476 Windows 8.1 or Windows 8.1 Pro

Posted by V64 on 11 April 2014 - 10:43 AM in Netduino 2 (and Netduino 1)

Hi Chris, Thank-you for your suggestion. I assume you are referring to my Laptop and W8.

 

The drivers folder contain amd64 folder, x86 folder and MFSUSB_Netduino security catalog and SetUp information.the amd64 folder contains an MFUSB_Netduiono.sys - is this the driver? (My ;laptop is an AMD A6). 

 

Device manager Search Automatically (for Netduino) cannot find Netduino Driver

 

Device Mnager Browse my computer - is set it to .../Drivers/amd64 - next says cannot find driver - search manual select from list of drivers - the list does not include Netduino

 

As for the SDK version - it looks like Netduio/Assemblies/v4.1

 

Thank-you - I hope I got the right set of answers.

 

David




#57465 Windows 8.1 or Windows 8.1 Pro

Posted by V64 on 10 April 2014 - 08:10 PM in Netduino 2 (and Netduino 1)

Help - I have two problems:

 

First

 

I am unable to access a Netduino board from my Laptop running W8.1. The windows Device manager says that the Netduino driver is not loaded and requests for an update say that drivers are not available - contact your device supplier!

 

I have no such problems accessing the board from W8.1 Pro (note PRO) running under Parallels VM in a Mac. Drivers are loaded  6.1.7601.17514 13/08/12 

 

Second

 

Using VS2010 Express on my Mac/Parallels/W8.1 Pro) I am unable to download my App. I get:

      "Deploy Succeeded" followed by "debug target not in initialised state; rebooting .... "

  

I get the same messages using VS2012.  

 

I am using Net.Micro v4.2 - I had the same problem when developing the app (but disconnecting/reconnecting the Netduino seemed to fix it for the next upload ) - but this was a while back and Parallels and Windows have had many updates since then.

 

Does Netduino supported in Windows 8 (Pro or otherwise)? If so what do I do next? 

 

Thank-you





home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.