Netduino home hardware projects downloads community

Jump to content


The Netduino forums have been replaced by new forums at community.wildernesslabs.co. This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

roy's Content

There have been 4 items by roy (Search limited from 26-January 20)


By content type

See this member's

Sort by                Order  

#1648 How to fix deploying to netduino hanging

Posted by roy on 01 September 2010 - 08:22 PM in Netduino 2 (and Netduino 1)

Yes I got the full output with all the attributes and assemly info printed out, the weird thing is it worked perfectly fine whilst I was trying it out at work, but upon getting home these problems started (shame I cant find the time to develop for it at work :rolleyes: ). Could it be IDE/OS related?

Ok I've flashed the Aplha firmware, and now it hangs on:
The debugging target is not in an initialized state, rebooting...

There was a hairy moment during flashing when the MFDeploy tool locked up on connecting to the bootloader, and I had to start the process again. Should I try reflashing?


hmm, not sure really, are you using the same usb cable? Maybe worth retrying the flashing again but to the more stable .2 version, but not really sure, it did take me two attempts to get it to flash fully - it is a bit hair raising seeing the memory getting erased!
Could well be the OS or drivers, take it you've tried reinstalling the sdk, rebooting etc.

Not sure I can help much, other than mention I'm on 64 bit windows 7 ultimate, 64 bit cpu, and a uniwill laptop - rebranded acer, esystem etc., with the express version of visual studio 2010 C#, if that gives you any pointers.

Failing that find a reason to borrow your machine from work ;)



#1645 How to fix deploying to netduino hanging

Posted by roy on 01 September 2010 - 07:57 PM in Netduino 2 (and Netduino 1)

I'm still having this issue even with the newer firmware :( any ideas on what else might cause it?


Are you sure the newer firmware flashed fully? It may appear to have - but actually have hung, only if you get both progress dialogs followed by a fair bit of output in MFDeploy (along the lines of sectors, read, written to) will it actually have been updated.



#1641 How to fix deploying to netduino hanging

Posted by roy on 01 September 2010 - 07:42 PM in Netduino 2 (and Netduino 1)

thanks for the welcome! I'm guessing that the UK stock is probably older, so there may be a few older ones like mine floating around.
And oops yes typo :rolleyes: that should read
Microsoft .NET Micro Framework 4.1 and not Microsoft ASP.NET MVC 1.0

roy

ah, just found the edit functionality, typo gone :)



#1638 How to fix deploying to netduino hanging

Posted by roy on 01 September 2010 - 07:17 PM in Netduino 2 (and Netduino 1)

I thought I'd summarise the following which I'd picked up from a few separate threads, as I had this issue when my brand new netduino arrived today and initially thought it was faulty. It should help someone else having the same problem as I had and save a few hours of frustration!

Problem:
Can connect to netduino, but when deploying from visual studio, deployment never finishes. Unable to ping netduino from MFDeploy, in other words netduino is there but unresponsive.

Solution: (Update to the latest firmware whilst in the tiny boot loader):
  • Download the latest firmware as of now (version 4.1.0.2, you'll need to be logged into this forum to download it.)
  • Unzip the contents to your hard disk
  • Start MFdeploy: Start Menu -> Microsoft .NET Micro Framework 4.1 -> Tools -> MFDeploy.exe (the one with the church window like icon).
  • Hold down the button (and keep holding it down) on the netduino while plugging it in (the blue light will stay on)
  • In MFdeploy change the Device to Usb and make sure your netduino is selected in the dropdown alongside (probably as netduino_netduino)
  • Now quickly click the ping button in MFDeploy before the netduino's blue light goes out.

You should now get a response something like:
Pinging... TinyBooter
Bootloader build info: Netduino by Secret Labs LLC


Now quickly before the tinyboot loader starts loading the .net framework code
  • click the browse button in MFDeploy and browse to where you unzipped the new firmware.
  • Select the ER_CONFIG and the ER_FLASH files, they will now be listed something like C:\netd\ER_CONFIG; C:\netd\ER_FLASH in the box.
  • Quickly click deploy, (you need to be quick before the boot loader exits - I didn't manage the first time and the deployment will hang before it starts if your too slow, just start again).
  • If it's working you should first see an erase progress bar followed by a writing (I think it was) progress bar.
The update will take a minute or two.

After this your netduino should be working normally.

Roy




home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.