Netduino home hardware projects downloads community

Jump to content


Photo

.net micro framework porting kit 4.2 build error


  • Please log in to reply
6 replies to this topic

#1 PKR

PKR

    New Member

  • Members
  • Pip
  • 3 posts

Posted 06 March 2013 - 06:36 AM

Hi all

 

I am new to .net micro frame work and visualstudio, i am interested in proting .net framework in ST arm microcontroller.

 

I have not purchased any board yet, but i have installed VS2010 express evaluation, keil MDK4.12 evaluation, .net micro framework 4.2 SDK & PK, i could  succesfully integrate micro frame work sdk wth vs2010 C# express.

but on building for porting kit via command line i followed the instruction:

 

cd C:MicroFrameworkPK_v4_2

C:MicroFrameworkPK_v4_2>setenv_MDK4.12.cmd c:KeilARM

C:MicroFrameworkPK_v4_2solutionsiMXSTinyCLR>MSBUILD.EXE /t:build /p:flavor=release;memory=flash  

i get the error "unable to find a version of the run time to run this application"

 

 

 

Kindly help where am i going wrong.

I have attached the text file of cmd prompt

error 2 text is while building & error1 text file is afterbuild complete.Attached File  error1.txt   20.55KB   6 downloadsAttached File  error2.txt   18.61KB   1 downloads

Thank you

 

 

 

 

 

 

 



#2 ziggurat29

ziggurat29

    Advanced Member

  • Members
  • PipPipPip
  • 244 posts

Posted 06 March 2013 - 05:41 PM

I don't personally use Keil, so maybe I can't be of huge help, but...

"unable to find a version of the runtime to run this application"  usually is symptomatic of not having the right .net framework version installed.

this link may (or may not!) help:

http://social.msdn.m...60-64c15e56577f



#3 PKR

PKR

    New Member

  • Members
  • Pip
  • 3 posts

Posted 07 March 2013 - 07:13 AM

Hi [color=rgb(50,50,50);font-family:Helvetica, Arial, sans-serif;]ziggurat29[/color]

 

[color=rgb(50,50,50);font-family:Helvetica, Arial, sans-serif;]Thank you, I have resolved that issue by adding [/color]MetaDataProcessor.exe.config file to in framework/tools folder where MetaDataProcessor.exe is present my problem got resolved but now i m getting build error . what could be the issue?

I have attached the text file of compile log.

 

Thank you

 

Attached Files



#4 ziggurat29

ziggurat29

    Advanced Member

  • Members
  • PipPipPip
  • 244 posts

Posted 07 March 2013 - 04:40 PM

You might have only masked the problem.  The MetaDataProcessor used by the porting kit is actually built from scratch, so you shouldnt have to copy it from anywhere.  The first step the build does is make the Win32 tools (including the metadataprocessor and other things), and then proceeds to make the ARM stuff (for your board).

But mention of the metadataprocessor takes me back, I seem to remember having something like that when I first started compiling the firmware -- in my case I think it was that I didn't have my devstudio environment vars set up so msbuild could invoke them correctly.  I'm not sure that's your problem, though, because you last error file indicates you are in the ARM building.  And the line:

  ...Aborts.cpp", line 19: Error:  #928: incorrect use of va_start

suggests to me that you've got some sort of toolchain setup issue, since va_start is standard C stuff.

Alas, I haven't worked with Keil, so I don't know I am much more help.



#5 CW2

CW2

    Advanced Member

  • Members
  • PipPipPip
  • 1561 posts
  • LocationCzech Republic

Posted 07 March 2013 - 05:44 PM

I am new to .net micro frame work and visualstudio, i am interested in proting .net framework in ST arm microcontroller.

 
Could you be please more specific on what ST microcontroller you want to port to? Because there are already several working ports for STM32F4 micros, which can be used for reference (and you would not need to waste time trying to get Freescale iMXS solution working - that or very similar error is discussed for example here ; )



#6 PKR

PKR

    New Member

  • Members
  • Pip
  • 3 posts

Posted 08 March 2013 - 06:25 AM

Hi CW2

 

I am using STM32F207Z controller. I m trying to compile the samples in the solutions to check how the output file are generated, but all solution folder gives me compilation error. I m facing compilation problem, i tried to compile the STM32stamp folder in the solution folder. I m getting 6 errors and 20 warnings does this file does not support keil MDK4.12 compiler. same is the case with all other folrs be it atmel or imxs folder the outcome is same.

Kindly find the attachment of log error.

 

 

Attached Files



#7 CW2

CW2

    Advanced Member

  • Members
  • PipPipPip
  • 1561 posts
  • LocationCzech Republic

Posted 08 March 2013 - 08:00 AM

Unfortunately, I don't have MDK 4.12, but if I try building STM32stamp solution from .NET MF PK 4.2 QFE2 with the following commands, it compiles fine:

C:MFPK42QFE2setenv_mdk 4.12 C:KeilARMC:MFPK42QFE2msbuild SolutionsSTM32stampdotnetmf.proj /p:Flavor=Release

I guess there is something wrong with the toolchain itself. If you don't have already installed other MDK or ARM RVDS which could conflict with 4.12, then I would recommend downloading newer version, up to 4.54 (inclusive). NET MF PK supports MDK 4.54 directly (setenv_mdk 4.54 ...). MDK 4.60 and newer require modifications in PK build system.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2010-2014 Secret Labs LLC  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.