Netduino home hardware projects downloads community

Jump to content

The Netduino forums have been replaced by new forums at This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

VS2013 and VS2015

  • Please log in to reply
3 replies to this topic

#1 J Wilson

J Wilson

    Advanced Member

  • Members
  • PipPipPip
  • 30 posts

Posted 20 January 2016 - 12:17 AM

I have Visual Studio Express 2013 for Windows Desktop.  I am able to create programs for my old Netduino 1 using it.


I also have Visual Studio Community 2015 installed.  I am not able to create any Netduino programs using it. Nothing related to Neduino appears in the templates under Micro Framework.


I have installed:

Microsoft .NET Micro Framework SDK 4.3 (SDK-QFE2)


Netduino SDK v4.3.2 (May 2015)


I will be taking delivery of my first Netduino 3 tomorrow and I want to be able to use it.


What am I missing to make VS 2015 work for Netduino?


Can I use VS 2013 to create projects for Netduino 3?


Thanks for any insights.



#2 J Wilson

J Wilson

    Advanced Member

  • Members
  • PipPipPip
  • 30 posts

Posted 22 January 2016 - 05:03 AM

After getting my Netduino3, I was able to create a program using VS2013 with the Netduino Universal template.


There was an initial compile error caused by the missing .NET 2,3.5 etc. Framework.  Installed those and everything compiled fine.


When I first tried to start debugging, it gave a "deployment failed" with no error codes.  So, I compiled a release version and deployed it without debugging.  That worked fine.  The next time I tried to start debugging it worked fine.  Don't know if had anything to do with the previous deploy.


But, everything is happy now!


I'm using VS2015 for Rasberry PI Windows 10 IoT development.  Probably just keep using VS2013 for Netduino.


#3 Nevyn


    Advanced Member

  • Members
  • PipPipPip
  • 1072 posts
  • LocationNorth Yorkshire, UK

Posted 22 January 2016 - 06:39 AM

I'm guessing but I think you might find that the project templates are in the Visual Studio 2013 templates directory.  I would try copying the Netduino templates from the 2013 template directory over to the 2015 templates directory and then restart VS 2015.




To be or not to be = 0xFF


Blogging about Netduino, .NET, STM8S and STM32 and generally waffling on about life

Follow @nevynuk on Twitter

#4 vader7071


    Advanced Member

  • Members
  • PipPipPip
  • 132 posts
  • LocationDothan, AL

Posted 03 October 2016 - 06:46 PM

Has anyone been able to get VS15 to work?  I was able to get a full blown copy of VS15 community and have not been able to get it to open a project created in VS12.   I get an error that the project is "incompatible".


I have upgraded and no longer have my VS12 up and running.


I loaded all the files from the website, and my option is "Netduino Universal".

When I try to create a new project I get an error "Missing project subtype.  Subtype [.....] is unsuppoted by this installation."

I looked at the upgrade log and the error I see is:

The application which this project type is based on was not found.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.