Netduino home hardware projects downloads community

Jump to content

The Netduino forums have been replaced by new forums at This site has been preserved for archival purposes only and the ability to make new accounts or posts has been turned off.

Updated Mini to 4.2, unable to connect or deploy projects

  • Please log in to reply
2 replies to this topic

#1 FourT2


    Advanced Member

  • Members
  • PipPipPip
  • 63 posts
  • LocationSeattle, WA

Posted 28 November 2015 - 07:14 AM

I was able to connect my Mini using Keyspan 19HS USB to RS232 adapter using the following configuration:

RX to ND pin1, TX to ND pin2, GND to ND pin 4, 5V to ND pin 12, and GND to ND pin 13.


Updated bootloader and flashed to 4.2 using SAM-BA 2.12.


But I am not able to connect to mini via PuTTY. It just sits at the blank screen and does not respond to Esc key.

(115200, 8 data bits, 1 stop bits, no parity, no flow control) 


Trying to deploy using VS 2015 shows this error: 

Opening port \\.\COM3
Port \\.\COM3 not found!
I've restarted the device a few times, and get same results.


MFDeploy can connect to device using Serial and shows device capabilities and device info:


HalSystemInfo.halVendorInfo:            Netduino Mini (v4.2.0.1) by Secret Labs LLC
HalSystemInfo.oemCode:                  34
HalSystemInfo.modelCode:                177
HalSystemInfo.skuCode:                  4098
HalSystemInfo.moduleSerialNumber:       00000000000000000000000000000000
HalSystemInfo.systemSerialNumber:       0000000000000000
ClrInfo.clrVendorInfo:                  Netduino Mini (v4.2.0.1) by Secret Labs LLC
SolutionReleaseInfo.solutionVendorInfo: Netduino Mini (v4.2.0.1) by Secret Labs LLC
SoftwareVersion.BuildDate:              Sep 19 2012
SoftwareVersion.CompilerVersion:        410894
FloatingPoint:                          True
SourceLevelDebugging:                   True
ThreadCreateEx:                         True
LCD.Width:                              0
LCD.Height:                             0
LCD.BitsPerPixel:                       0
AppDomains:                             True
ExceptionFilters:                       True
IncrementalDeployment:                  True
SoftReboot:                             True
Profiling:                              False
ProfilingAllocations:                   False
ProfilingCalls:                         False
IsUnknown:                              False
  HAL build info:, Netduino Mini (v4.2.0.1) by Secret Labs LLC
  OEM Product codes (vendor, model, SKU): 34, 177, 4098
  Serial Numbers (module, system):
  Solution Build Info:, Netduino Mini (v4.2.0.1) by Secret Labs LLC
    default, id=1


I feel that I am getting close but not sure what else I am missing :-). Any ideas on how to proceed from this point?

#2 FourT2


    Advanced Member

  • Members
  • PipPipPip
  • 63 posts
  • LocationSeattle, WA

Posted 28 November 2015 - 07:38 AM

Even though PuTTY just sits at a blank screen and ignores Esc key presses, if I leave the session open and power cycle the board, the following is dumped to console:


.NetMF v4.2.0.0
NetduinoMini, Build Date:
        Sep 19 2012 19:40:47
ARM Compiler version 410894
TinyCLR (Build
Created EE.
Started Hardware.
MSdbgV1?V???Create TS.
 Loading start at 13ed64, end 154648
   Assembly: mscorlib (
                                  Assembly: Microsoft.SPOT.Native (
                                                                              Assembly: Microsoft.SPOT.Hardware (
                                                                                                                            Assembly: Microsoft.SPOT.Hardware.SerialPort (
                                                                                                                                                                                     Assembly: Microsoft.SPOT.IO (
                                         Assembly: System.IO (
                                                                         Assembly: Microsoft.SPOT.Hardware.PWM (
                                                                                                                           Assembly: SecretLabs.NETMF.Diagnostics (
                                                                                                                                                                              Assembly: SecretLabs.NETMF.IO (
                                 Loading Deployment Assemblies.
Cannot find any entrypoint!
MSdbgV1?;       Waiting for debug commands...

#3 FourT2


    Advanced Member

  • Members
  • PipPipPip
  • 63 posts
  • LocationSeattle, WA

Posted 28 November 2015 - 07:48 AM

Ok, just tried this and it appeared to work:


Downloaded and used this version of MFDeploy (rather than installed 4.3 version): http://forums.netdui...b-and-com1com2/and selected COM2. 


Keyspan 232 adapter is known as COM3 to the system


In VS 2015, Deployment transport: Serial, COM3.


Looking for a device on transport 'Serial'
Found device port 'Serial' with ID '9743cc25-f2d4-4cfd-bdb8-75a7b0b6f104' for transport 'Serial'
Starting device deployment...
Attempting to connect to device 'Serial:COM3' Iteration 0
Opening port \\.\COM3
Attaching debugger engine...
... debugger engine attached!
Querying device assemblies...
Found Assembly mscorlib
Found Assembly Microsoft.SPOT.Native
Found Assembly Microsoft.SPOT.Hardware
Found Assembly Microsoft.SPOT.Hardware.SerialPort
Found Assembly Microsoft.SPOT.IO
Found Assembly System.IO
Found Assembly Microsoft.SPOT.Hardware.PWM
Found Assembly SecretLabs.NETMF.Diagnostics
Found Assembly SecretLabs.NETMF.IO
Adding pe file C:\Program Files (x86)\Secret Labs\Netduino SDK\Assemblies\v4.2\le\ to deployment bundle
Adding pe file d:\users\andrew\documents\visual studio 2015\Projects\NetduinoMiniApplication2\NetduinoMiniApplication2\bin\Debug\le\ to deployment bundle
Adding pe file C:\Program Files (x86)\Secret Labs\Netduino SDK\Assemblies\v4.2\le\ to deployment bundle
Attempting deployment...
Incrementally deploying assemblies to device
Deploying assemblies for a total size of 1424 bytes
Assemblies successfully deployed to device.
I am not 100% sure why this worked. I was selecting deployment model in VS the same way before, and it was not able to find my device on COM3 (that Keyspan adapter was attached to). 

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.