Netduino home hardware projects downloads community

Jump to content


Photo

.NET MF 4.3 or > and Visual Studio

.NET MF Visual Studio

  • Please log in to reply
6 replies to this topic

#1 eschneider

eschneider

    Member

  • Members
  • PipPip
  • 16 posts

Posted 14 April 2015 - 04:39 PM

Has anyone used anything newer than 4.2 on the Mini?

 

Cany anyone give me a quick rundown on .NET MF versions work with what visual studio version?

 

I'm a professional software developer and currently use VS2013 Pro, but plan to use 2015 soon.

 

Thanks,

 

Eric



#2 Chris Walker

Chris Walker

    Secret Labs Staff

  • Moderators
  • 7767 posts
  • LocationNew York, NY

Posted 14 April 2015 - 05:42 PM

Hi Eric,

The Netduino 4.3.1 SDK includes support for NETMF 4.2 projects as well. I use the Netduino 4.3.1 SDK myself (in conjunction with the NETMF 4.3 QFE2 SDK)--and just change the target framework version to 4.2 for older boards.

VS2015 support is still technically beta-ish for NETMF, but the Netduino 4.3.1 SDK already supports it too :)

Chris

#3 eschneider

eschneider

    Member

  • Members
  • PipPip
  • 16 posts

Posted 14 April 2015 - 07:11 PM

so you have flashed MF 4.3.1 to the Netduino mini also?



#4 Chris Walker

Chris Walker

    Secret Labs Staff

  • Moderators
  • 7767 posts
  • LocationNew York, NY

Posted 14 April 2015 - 09:52 PM

Hi eschneider,

4.2 is the latest firmware for Netduino Mini. But you can use the Netduino 4.3.1 SDK to target boards running NETMF 4.1, 4.2 or 4.3.1.

Chris

#5 Razvan

Razvan

    New Member

  • Members
  • Pip
  • 6 posts

Posted 12 May 2015 - 03:48 AM

Is it possible to compile myself NETMF 4.3 for Netduino Mini ?



#6 kiwi65

kiwi65

    Member

  • Members
  • PipPip
  • 23 posts

Posted 14 June 2015 - 07:46 PM

Chris, I'm keen to understand the relationship between NetMF version, SDK version and hardware.

 

I see above that we can use the Netduino 4.3.1 SDK with a Mini. I'm wanting to update my Mini project with the most stable versions of NetMF and SDK.. and note there's a newish 4.3.2 SDK. Should I install that? 

 

Have been struggling to get my Mini talking I2C to a common eeprom.. and have pretty much removed software and hardware from the problem domain ... so hoping it's something to do with SDK versions.



#7 Chris Walker

Chris Walker

    Secret Labs Staff

  • Moderators
  • 7767 posts
  • LocationNew York, NY

Posted 15 June 2015 - 09:28 PM

Hi kiwi65,

Chris, I'm keen to understand the relationship between NetMF version, SDK version and hardware.
 
I see above that we can use the Netduino 4.3.1 SDK with a Mini. I'm wanting to update my Mini project with the most stable versions of NetMF and SDK.. and note there's a newish 4.3.2 SDK. Should I install that?

Since you can only have one version of the NETMF and Netduino SDKs installed at a time, we include support for older firmware in new SDK releases. The actual NETMF 4.2-based code delivered to your board will be the same, using the 4.3.2 SDK.

Chris




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.