Netduino home hardware projects downloads community

Jump to content


Photo

Device does not respond..


  • Please log in to reply
3 replies to this topic

#1 dingir

dingir

    New Member

  • Members
  • Pip
  • 2 posts

Posted 14 January 2011 - 08:42 PM

Hi, I recieved my NetDuino yesterday. I tried the flash-thing and then I was curious setting up the ethernet-communication. I was enabled the DHCP on my NetDuino, now I can't deploy from VS neither ping from MFDeploy. I feel any of these are needed to make the netduino back to static ip. Sometimes I can ping from MFDeploy, maybe 1 of 3 tries. It appears that ping returns "TinyCRL" if i ping same second i re-attach the usb cable. How do i solve this issue?

#2 Chris Walker

Chris Walker

    Secret Labs Staff

  • Moderators
  • 7767 posts
  • LocationNew York, NY

Posted 14 January 2011 - 09:03 PM

Hi dingir, Sorry that you're having troubles. No fun. If you hold down the pushbutton on your Netduino Plus while plugging it into your computer, it'll go into "bootloader" mode for 5 seconds. You can erase your current app in this mode (which should clear up any non-responsiveness issues). You can also change your network settings in this mode or update your Netduino Plus's firmware. We're hunting down a few DHCP-related glitches in the .NET MF/lwIP core networking code. Pascal and a few other community members identified two issues, and we're working on a third. If you're working well with static IP but having glitches with DHCP, any info you have would be greatly appreciated. We have an update coming out next week that we'd like to address this in if possible. Thanks, and welcome to the Netduino community! Chris

#3 dingir

dingir

    New Member

  • Members
  • Pip
  • 2 posts

Posted 14 January 2011 - 09:56 PM

Thank you for a quick reply and an easy solution to clear the rom. (5 seconds and the Erase function in MfDeploy). Worked well, now i'm up and going again :). There is something in the NetLog class that the system don't like (just copy / pasted in this stage of knowlegde). One another though is how I handle the ip adressing. I've set a ip-adress that corresponds to my local network, but how are the device expected to work with tcp/ip communication? I understand that I need SocketClient/SocketServer for communication but, 1. MFDeploy, changing the communication to tcp/ip 2. VS2010-buildoptions, changing the communication to tcp/ip 3. Using windows/dos prompt command PING to static adress of the device (no reply when trying) I asked the device for it's ip address and it responded 192.168.11.23.. gateway 11.1, subnet /24 and so on.. :)

#4 Chris Walker

Chris Walker

    Secret Labs Staff

  • Moderators
  • 7767 posts
  • LocationNew York, NY

Posted 14 January 2011 - 10:00 PM

Hi dingir, You can use the network feature of Netduino Plus to send/receive data, but to deploy/debug Netduino Plus you'll use USB or Serial. .NET MF does support Ethernet-based debugging, but only on devices with a lot of storage space and memory (i.e. $100s). If you set a static IP address on your Netduino Plus, try the SocketClient app in the Micro Framework SDK. Does it get data from the Internet? [Make sure to set/clear the proxy server settings in the code.] Chris




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

home    hardware    projects    downloads    community    where to buy    contact Copyright © 2016 Wilderness Labs Inc.  |  Legal   |   CC BY-SA
This webpage is licensed under a Creative Commons Attribution-ShareAlike License.